...

View Full Version : Internal Server Error for no good reason?



storky
04-02-2011, 09:53 PM
My site has quite a bit of php files on it already.

I all of a sudden get the following error for no reason that I can find:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, webmaster@workouts.mytrainingbuddy.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.


Deleted all of my code and just put in a hello word echo and still have this error. I have just started using aptana because I was sick of dreamweavers poor ftp. Doubt that makes a difference but you never know.

The rest of the site is completely fine. There is no .htaccess file on the folder.

any help would be great. thanks.

djm0219
04-02-2011, 10:04 PM
Have you looked at the web server error log as the message suggests? The clue you are looking for is likely there.

Lamped
04-03-2011, 12:08 AM
Depending on your setup, if you have a public_html folder, check it's owned by you, and group "nobody". Use the following to set this:


chown myusername:nobody public_html
Changing myusername to your username.

If your apache is setup in a certain way, you may need to "own" all the documents being served. See above but put -R after chown.

Make sure each file has read access to all. That's a minimum permission of 0444.

tangoforce
04-03-2011, 12:12 AM
I have just started using aptana because I was sick of dreamweavers poor ftp. Doubt that makes a difference but you never know.


I've heard of this before and it was down to either the upload type being wrong (binary/ASCII) or the encoding of the text file. I had the encoding problem myself using notepad++ and it took me days to solve it.

Lamped
04-03-2011, 12:49 AM
The difference between binary and ascii mode is in the handling of line endings, which shouldn't cause a server error. It's strange you seemed to find this, tangoforce.

Then again, I wouldn't really know for certain, I develop with Komodo IDE on Linux, and rsync my files to the server with no need for line ending translation.

storky
04-03-2011, 10:51 AM
Thanks for all the replies. I am going to check the encoding possibility right now but have made modifications to existing files fine. I also copied an existing file and just renamed it and uploaded it to see what would happen and didn't have any luck there either.

Uploading a new html file works fine :confused:

checked my error log and I am getting a whole lot of these:


[Sun Apr 03 03:44:26 2011] [warn] RewriteCond: NoCase option for non-regex pattern '-f' is not supported and will be ignored.

In the main error log. Nothing at all in the php logs. I am looking up what this means now. I am not familiar with this.

edit: Looked on the Aptana website. says that all ftp is done via binary upload right now. Would that cause this?

storky
04-03-2011, 11:07 AM
Figured it out. Had nothing to do with coding at all or format. Aptana was uploading with 666 permissions. Not being able to execute seems to have been the problem. Maybe this will help someone else. Thanks for your suggestions

Lamped
04-03-2011, 11:23 AM
Did it upload the folders with 0666 too?

storky
04-03-2011, 11:25 AM
Yes it did. I just submitted a suggestion to the dev team to change that default setting, or at least give users the chance to change it before creating a new connection. Right now it is buried in some sub menus.

644 would be appropriate right?

Lamped
04-03-2011, 12:57 PM
Thought so...

Unless you have a good specific reason to do so, folders should be executable. This is 1, 3, 5, or 7.

1 and 3 don't make much sense, so every folder should be 5 or 7: 0555, 0777, 0755 etc. You probably want 0755.

tangoforce
04-03-2011, 01:57 PM
The difference between binary and ascii mode is in the handling of line endings, which shouldn't cause a server error. It's strange you seemed to find this, tangoforce.

Then again, I wouldn't really know for certain, I develop with Komodo IDE on Linux, and rsync my files to the server with no need for line ending translation.

Yeah i normally use cuteFTP's auto option but once decided i was smart enough to do it manually.. big mistake.

The encoding in the editor however has caused me problems of this nature though and is more likely to be the issue than the mode of upload out of my two suggestions.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum