View Full Version : masterpage with images problem.

03-06-2011, 02:49 PM
Hello cf, im new to this website and also new to ASP.net.

i have a masterpage, and iv linked some other pages to it and have it successfully displaying "welcome to the site from masterpage" just so i know all was working fine, i tried to add my banner image, when i debug the image would appear then dissapear or sometimes not appear at all. the image is in the right directory. and its appearing with the design view of visual studio so its reaching the file but for some reason its not showing. i just dragged and dropped.
iv tried:
putting it into a table.
using the following:

<asp:Image ID="Image1" runat="server" AlternateText="banner" ImageUrl="images/banner.jpg"/>

<img src = "images/banner.jpg" alt = "alt"/>

<p><img alt="" src="images/banner.jpg" style="width: 800px; height: 150px" /></p>

the weird thing is when i try a different image it will add it just fine and never dissapear. my banner is 800x150 and 115kb. a differant image that works is 321x489 and is 41.4kb. im completely out of ideas, im dragging and dropping so file path shouldnt be the problem. help would be great :)

03-14-2011, 12:55 PM
Why don't you try with another image of size 800x150, just try and see, whether it works or not

03-16-2011, 06:58 PM
i fixed the problem..kinda, turns out i wasnt doing anything wrong. i didnt test in a different browser which was probably really stupid of me... the problem was my google chrome configuration, im going to guess it was a conflicting extension but who cares, it works now :)