...

View Full Version : Ok Mystery Issue with CSS Menu and BG Image.



wesslayneb
12-23-2010, 07:06 AM
Ok so me and my partner just launched our new layout on our website. But we have an issue. On the index our menu works just fine (www.lcudclan.com), but when you venture off to other pages like (lcudclan.com/members.php) then the menu does not work. The menu only works with the index, and me, my partner, nor HostGator Tech Supports agents can find the issue. Ok so here is the issue.

(Use the HTML code to go along with all the things during my description of the issue.) The background image on the top of our webpage (lcudclan.com) covers the top, plus is the blue/red background for the menu. And all of that is in the core.css (as defined in the HTML). But the menu properties itself (background color, width, height, rollover, etc.) are all in the /menu folder (again as defined in the HTML). Now on index.php the menu works fine no issues. But on any of the other pages in the root folder (the root folder is the only folder that has this design) the menu does not work, it does not display the bottom of the background image that it should display.

Below is my partners description of the issue, as he is the developer of the layout.

RapideGT
12-23-2010, 07:16 AM
OK to all of you immature minds, by "partner" he meant web design partner, of course. :)

When you look at the navigation bar/menu on the index page, you see the blue/red bar that goes across the screen. When you hover over it, that section is replaced by the same dark gray that is in the background. By default, the menu is set to 0% opacity, but when you hover, it goes to 100% #252525...

When you venture off onto the other pages with the same design, it is by default the same dark gray as the background, and the same when you hover over it. So, any idea what the issue seems to be?

Excavator
12-23-2010, 08:44 AM
Hello wesslayneb and RapideGT,
On the home page, .eBanner is margined down so it doesn't cover the parent ul of your menu.
On other pages there is no .eBanner and .contentPage covers the parent ul, I think because of collapsing margins (http://nopeople.com/CSS%20tips/uncollapsing-margin/index.html).

On pages that have .contentPage, add this bit in red -

.contentPage {
width:980px;
background:#252525;
padding:10px 10px 10px 10px;
margin: 50px 0 0 0;
}

This would work equally well -

.contentPage {
width:980px;
background:#252525;
padding:10px 10px 10px 10px;
clear: both;
}

wesslayneb
12-23-2010, 10:10 AM
Thank you very much, this fixed our issue!



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum