...

View Full Version : Easy Slider jQuery Plugin



knightrider01
12-19-2010, 05:13 AM
I set up the Easy Slider jQuery Plugin for this page (http://www.actionmarketers.com/new/), based on this tutorial (http://cssglobe.com/lab/easyslider1.5/) and this demo (http://cssglobe.com/lab/easyslider1.5/02.html), and the 4 images are showing up in a vertical column rather than being able to click to the next image. What am I doing wrong? Also, I don't see the next/prev arrow buttons, but that may fix itself once the images are positioned correctly.

eberdome
12-19-2010, 07:00 AM
post all your code! I am viewing from phone. some normal mistakes that one can make are fairly simple mistakes. do you have jquery library included for one? is your div name the same in your jquery and HTML? post all code including your jquery that you are suppose to include in your header! thx

Excavator
12-19-2010, 09:00 AM
Hello knightrider01,
You've copied the CSS exactly and it's styling a ul in a div called #slider.

Your markup has no #slider. Your images are in a ul contained in a div called #images.

It also looks like your easySlider.js is not a .js at all, it's an HTML document misnamed as easySlider.js.

eberdome
12-19-2010, 07:37 PM
you need to import your easySlider.js file into your root folder. the html that Excavator is reffering to is a page that does not exist. you need to upload easySlider.js, and the same thing for jquery.js you need to have the library in order to use jquery. once you have these two documents uploaded then you need to change <div id="images"> to <div id="slider">. let me know if it works after that!

knightrider01
12-31-2010, 05:17 AM
ok, so I think I made the updates you both mentioned, and here's (http://www.actionmarketers.com/new/) where I'm at.

The images show up side by side across to the right rather than being in the "slider" format from the demo. I don't know what else I am missing.

Excavator
12-31-2010, 10:01 AM
ok, so I think I made the updates you both mentioned, and here's (http://www.actionmarketers.com/new/) where I'm at.

The images show up side by side across to the right rather than being in the "slider" format from the demo. I don't know what else I am missing.

Getting closer. You're still missing some things though...
the link to btn_next.gif and btn_prev.gif come up 404 and your CSS is still not matching the one your copying.
Your missing
/* image replacement */
.graphic, #prevBtn, #nextBtn{
margin:0;
padding:0;
display:block;
overflow:hidden;
text-indent:-8000px;
}
/* // image replacement */


I think you need to go through that tutorial again. Just start at the beginning and go through each step again.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum