...

View Full Version : Help - Link Button Doesnt Work IN IE



Paul2010
12-15-2010, 05:42 PM
Hi guys,

As a person with VERY little HTML knowledge Im getting very frustrated with a situation "I'm sure its a simple fix" that I hope you can help me with - there are 2 issues:-

1 - when you click on the Orange button on my website in IE the link doesnt work "it works when you right click - open link in a new tab"

2 - when you click on the Orange button on my website in Firefox - 2 tabs open instead of 1??

Any help would be very much appreciated - the link is http://www.twessential.com/newhome.html. If any files are need please let me know

Many thanks

VIPStephan
12-15-2010, 06:04 PM
Why are you using an input element when youíre not using a form? A regular image link would be the proper use here.
Why are you using tables at all for your page layout? Thatís a method from 15 years ago.

Paul2010
12-15-2010, 06:07 PM
Hi VIPStephan,

The page was given to me by a friend to customise as I wish - any idea on how to solve the problem?

VIPStephan
12-15-2010, 06:09 PM
Yeah, as a quick but dirty fix change
<a target="_blank" href="http://www.tweetadder.com/idevaffiliate/idevaffiliate.php?id=3229&amp;url=764"><input type="image" src="images/submit-image.jpg"></a> to
<a target="_blank" href="http://www.tweetadder.com/idevaffiliate/idevaffiliate.php?id=3229&amp;url=764"><img src="images/submit-image.jpg" alt="Take me to the free tweet adder trial version." /></a>

Paul2010
12-15-2010, 06:16 PM
Thanks for that - it works perfectly in IE and FF now, but theres a problem in that theres a blue rectangle box around the button!! I used the code below:-

<tr><td align="center" colspan="2"><a target="_blank" href="http://www.tweetadder.com/idevaffiliate/idevaffiliate.php?id=3229&amp;url=764"><img src="images/submit-image.jpg" alt="Take me to the free tweet adder trial version." /></a></td></tr>
</table>

Paul2010
12-15-2010, 08:08 PM
The link in my previous post had a full stop at the end thats why it may not have worked for you please see http://www.twessential.com/newhome.html

Stephan if you could reply that would be good as its just the rectangle blue box issue now

VIPStephan
12-15-2010, 09:03 PM
OK, on with the dirty fixes. The blue border is a default for images inside anchor elements (i. e. links). To remove the border, just add style="border:0;" to the image element, e. g. after the text of the alt attribute.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum