...

View Full Version : Resolved puzzled: form submit button works in every browser but IE



teedoff
12-13-2010, 06:56 PM
Ok I dont know whats happened, as far as I know I didnt change any code to cause this. I have a page builder with a form so employees can build new pages.

Everything works great in firefox, safari, chrome, and opera. When I try to create a page in IE however, the submit button does nothing. I've tested it locally and remotely and the button acts like there is no form action set to it.

Again, same page works for all other browsers. Here is a link to the page template.cfm (http://teed-younger.com/pageBuilder/template.cfm).

I'm missing something, so maybe someone else can spot my error. Thanks!

btw, I have 2 validation errors on my page, and one I think is saying I have a mismatched <form> tag, but for the life of me I cant figure out where the mismatch is coming from. When I add a closing form tag it doesnt work either.

DrDOS
12-13-2010, 07:27 PM
name="button" Could be that you are using an HTML element name as the name of the input, doesn't take much to confuse IE.

teedoff
12-13-2010, 09:11 PM
Hey Doc, thanks for the reply!...I figured it out..I had some nested forms within my <cfform>. This was a page I copied the source code from in order to make it look like our already exsisting pages. That way the girl creating the new pages would have the look and feel of how the pages are currently laid out.

Anyway, the other forms were cart forms, so I just removed them, since they arent needed.

Thanks again!



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum