...

View Full Version : Javascript slider messing up the rest of the site....need help!



CarlMartin10
08-25-2010, 03:24 PM
OK, a friend and I have been working on implementing the javascript slider you see in the header of my website http://www.billboardfamily.com (hover over the facebook icon under the search area).

For some reason, this is causing a lot of the other items on the site to stop functioning all together. Can anyone help me figure out how to fix this?

NOTE: Running Wordpress

Here are some of the problems:

1) http://billboardfamily.com/videos/ The thumbnail videos do not work when you click them
2) http://billboardfamily.com/the-process/ All 4 slides are on the page, but the slider is not working at all.
3) http://billboardfamily.com/contact-us/ The contact forms I have running are not working correctly, and the styling is no longer correct.

Oneilius
08-25-2010, 11:24 PM
I'm not exactly sure to what you're referring as far as the JavaScript slider in your header goes. I do see a lot of JavaScript files called in your <head> code, but there is enough script there that I'd rather not browse through it to find what's faulty. Also, I don't see any explicit calls to your script: on-event handlers (onLoad, onClick, onMouseover, onChange, etc.) or the like.

I looked at the 3 issues you listed below and didn't see any problems. The videos load (but don't autoplay — did you want them to?); the slides work when I click the vertical "tabs"; the styling on the /contact-us/ page seems OK to me at first glance — how should it be differently styled?

Can you indicate where specifically the trouble is (e.g., indicate a function that is failing or specify an element that has its alignment or functionality off)? If possible, please include a code snippet of both the JavaScript and associated HTML where the problem lies. (For instance, if an element should call a JavaScript function, include the function that isn't working and the place in your HTML where the function is called.)

(By-the-by, I did notice you have no href attribute in your link for the Facebook icon.)

Oneilius

CarlMartin10
08-26-2010, 06:57 AM
I'm not exactly sure to what you're referring as far as the JavaScript slider in your header goes. I do see a lot of JavaScript files called in your <head> code, but there is enough script there that I'd rather not browse through it to find what's faulty. Also, I don't see any explicit calls to your script: on-event handlers (onLoad, onClick, onMouseover, onChange, etc.) or the like.

I looked at the 3 issues you listed below and didn't see any problems. The videos load (but don't autoplay did you want them to?); the slides work when I click the vertical "tabs"; the styling on the /contact-us/ page seems OK to me at first glance how should it be differently styled?

Can you indicate where specifically the trouble is (e.g., indicate a function that is failing or specify an element that has its alignment or functionality off)? If possible, please include a code snippet of both the JavaScript and associated HTML where the problem lies. (For instance, if an element should call a JavaScript function, include the function that isn't working and the place in your HTML where the function is called.)

(By-the-by, I did notice you have no href attribute in your link for the Facebook icon.)

Oneilius

I completely removed the sliding menu so I could work on the rest of the site without it being messed up. Once the rest of the site is done, I will try another go at the sliding menu, and if it still is problematic....I will post on this forum. Thanks



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum