...

View Full Version : IE bug using Gallerific



iammow
08-22-2010, 03:13 PM
Hi there, I'm building a website and using Jquery's Gallerific for a gallery page, every other page shows up fine in IE, but in IE7 and below the page using gallerific leaves a large space above the photo and displaces the navigation. I'm really not sure why and was wondering if somebody who's more of a CSS buff might have an idea?

Here's the problem:
http://api.browsershots.org/png/original/64/6466e9ab6e00238189beb70a2aa868a8.png

Here's the page online:
http://www.amythornley.co.uk/testfiles/gallery.html

view source for codes.

Thanks for any help anyone can offer.

abduraooft
08-23-2010, 09:50 AM
Try
*{
margin:0;
padding:0;
}
#content
{
/*width: 415px;*/
margin-left: 0px;
margin-right: 300px;
padding-top: 0px;
padding-right: 9px;
padding-bottom: 10px;
padding-left: 23px;
}
#rightthumbs
{
float: right;
width: 260px;
margin-left: 0px;
margin-right: 19px;
padding-right: 9px;
padding-bottom: 10px;
padding-left: 9px;
margin-top: 19px;
padding-top: 0px;
}

iammow
08-23-2010, 10:56 AM
Thanks for the reply but still have the same problem, I've only tested in IE7 so I'm not sure if this is an IE7 alone issue or all those below. Still the nav going to the left and the gap before the main photo.

http://www.amythornley.co.uk/testfiles/gallery.html

I am now using a seperate stylesheet, style2.css to keep from messing around with the other pages, there is also css in gallerific-2.css that could be causing the problem but I'm not sure which part.

Any more suggestions are greatly appreciated, trying to finish this for a client asap.

abduraooft
08-23-2010, 11:00 AM
Still the nav going to the left and the gap before the main photo.
Have you updated the online version with the change that I've given?

iammow
08-23-2010, 11:08 AM
I have indeed.

The css file is here: http://www.amythornley.co.uk/testfiles/style2.css

lemme know if it needs changing around or something.

ETA: The navigation is also displaced on the contact page, despite it using exactly the same css as the other 3 pages which are fine. Internet Explorer is really a mystery..

abduraooft
08-23-2010, 11:52 AM
Now, remove that big line-height from div.slideshow a.advance-link

iammow
08-23-2010, 12:30 PM
Okay thankyou, thats sorted the space at the top of the photo. Now theres just the problem of the navigation shifting to the left which happens on the gallery and contact page, must be something to do with the main stylesheet but I'm not sure what as it's fine on the other pages?

iammow
08-24-2010, 02:43 PM
Any ideas about the navigation yet? I really am at a loss, could it be the right div pushing the navigation out?



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum