...

View Full Version : site not working in Win IE7, but works in Mac and other Win browsers



mamaglee
07-31-2010, 03:42 AM
Hello, I am working on a site, not yet complete, but the white background should appear over the background of the lavender fields. It does for all browsers except Windows IE7, yet the template from which I created this site works fine in Windows IE. When I changed something in the css, I messed up the layout for the white background image. Can somebody help me? I don't have a Windows machine but my client for whom the site is being made, uses Windows Firefox and IE 7, and said it looks find in Firefox, but not IE7. :eek:

Not working: http://www.goddessspring.com/ie7.html based on the working in IE7 site below...

Working: http://www.gordonmac.com/downloads/html/demos/Peace/

Should look like the image here: http://goddessspring.com/web_draft.jpg

Thanks for any help with my css. :confused:

SB65
07-31-2010, 08:09 AM
It looks like a hasLayout (http://www.satzansatz.de/cssd/onhavinglayout.html) issue. Try adding:


#wrapper-3 {
background:url("images/bg_wrapper-3.jpg") repeat-y scroll 0 0 transparent;
color:#333333;
text-align:left;
height:1%;
}

The height 1% will set the hasLayout property in IE7 (and below), which sorts out the issue.

mamaglee
07-31-2010, 04:11 PM
Thank you so kindly for your prompt reply. I didn't know about the hasLayout property and I appreciate your fixing this for me. Hooray.

I also found this web tool, that now allows me to view the site in different browsers that I don't have on my computers:
http://ipinfo.info/netrenderer/index.php

Cheers, very pleased. Mamaglee



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum