...

View Full Version : mailto link displaying "localhost" when used from htaccess file



mb89
05-31-2010, 03:36 AM
Hi,

I was hoping to hide my mailto links in the htaccess file and it seemed to be working perfectly however I figured out today it's doing something weird. When you hit on the email link, the email address in the to box is xxx@xxx.comlocalhost/

It appends this weird "localhost/" to the end of the email address and I have no clue why! My option to get around it is to redirect to a PHP file that headers to the mailto link but I was hoping to keep it in my htaccess and nice and tidy.


RewriteRule ^contact/email$ mailto:xxx@xxx.com.au [L]

Hopefully you can help me =)

Cheers,
mb89

hoothelp
07-07-2010, 11:13 AM
Hello,

Odd - Not sure where to start with this one. I setup the same rewrite rule on my domain and I'm not getting the behavior you are experiencing. Try it out (http://www.codelyrics.com/contact/email) and let me know what it does for you.

If you still get the appended localhost - it is likely something occurring on your local network/computer. If you don't then it's a setting somewhere on the server.

I assume that a mailto link hard-coded in HTML served from your server doesn't append the locahost text? It sounds like that's what you are doing with the PHP file.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum