...

View Full Version : Problem with my Layout :/ CSS Problems



gregory1989
05-30-2010, 12:51 AM
Hey guys, I am new to the forums :)

I have been searching for an answer for this for hours now and its driving me insane!

My website www.wowultima.darkhybrid.com, If you see the left hand navigation the text is overlapping the div and the footer and is leaving its boundaries. Yet if I add more <p> tags of information in the middle of my content the background will stretch. I dont get why my navigation is overlapping whereass I can add as much information in I want in the middle and it wont do this!

My CSS is located here:

http://www.wowultima.darkhybrid.com/style.css

If you want I can post my index.html file on here if needed!

Please can someone help guys :(

Excavator
05-30-2010, 02:14 AM
Hello gregory1989,
The link you posted is the best source of information, no need to post your index file in the forum as we can see it from the link.

Floats are the best way to place columns beside each other. Try making your CSS look like this -


#container {
/*float:top; no such thing
height:100%;*/
width:800px;
background:url(http://www.wowultima.darkhybrid.com/images/contentbg.jpg);
/* margin-top : 0px;*/
margin: 0 auto;
padding: 0 ;
overflow: auto; /*to clear the floats*/
}


#navigation {
width:100px;
float: left;
/*display: block;
position:absolute; top:280px;
margin: 0 auto;*/
margin: 0;
padding: 0;
min-height: 100%;
}


#content {
margin: 0 0 0 100px;
/*
display: block;
float:top;
height:auto
width:500px;
position: relative;
margin: 0 auto;
margin-top : -15px;
padding: 0 0 0px 0;
margin-left : 220px;
clear: both
*/
}
That's based on this method of a two-column layout (http://nopeople.com/CSS/simple_2-column/index.html).

gregory1989
05-30-2010, 10:05 AM
Hey,

Thanks that did work how ever I am now getting a new problem as there seems to be a big space after my break div from my content div and there is a gap.

http://wowultima.net/

If you look at the content area you will see what I mean.

Any advice?

gregory1989
05-30-2010, 10:43 AM
Please anyone guys :( I am pulling my hair out here trying to figure whats wrong :/

Excavator
05-30-2010, 11:14 AM
I've commented out some CSS here -
.menu li{
/*padding-right:10px;
margin:0 5px 0 0;
margin: 0 auto; */
padding: 0;
/*height:100px;
list-style-type:none;
list-style:none;*/
display:inline;
float:left;
}

gregory1989
05-30-2010, 11:31 AM
You sir are a legend :D

Wordpress is now working a treat

www.wowultima.net/wordpress

Love this forum you guys rule!



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum