...

View Full Version : Internal Server Error



TheJoey
05-01-2010, 05:50 AM
<Directory >
AuthType Digest
AuthName "research"
AuthUserFile research.user
Require valid-user
</Directory>


it works fine as a basic auth type, is there something i need to install for digest to work?

im getting these error

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator, you@example.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

More information about this error may be available in the server error log.

MattF
05-01-2010, 01:33 PM
More information about this error may be available in the server error log.


Which says?

TheJoey
05-01-2010, 07:22 PM
[Sun May 02 04:21:30 2010] [crit] [client 114.76.121.8] configuration error: couldn't check user. No user file?: /admin/
[Sun May 02 04:21:34 2010] [crit] [client 114.76.121.8] configuration error: couldn't check user. No user file?: /admin/

MattF
05-01-2010, 07:31 PM
Judging from those errors, I'd guess you have no file with the:



user:realm:pass


entries in?

TheJoey
05-02-2010, 06:05 PM
im not sure what you mean, i used htpasswd to make the file

my file has
username:encrypted password

Inigoesdr
05-04-2010, 05:42 AM
Is the path correct?

AuthUserFile research.user

TheJoey
05-05-2010, 04:34 AM
Well i worked out the issue here but ran into another
how do i install the mod_auth_digest modules?

Samhain13
05-05-2010, 06:08 PM
^ On Linux, do this in the command line:

a2enmod auth_digest
You might have to use "sudo" or do it as "root". Then restart your webserver.

On Windows, I have no idea.

TheJoey
05-06-2010, 04:26 AM
Syntax error on line 234 of /iweb/s3138130/apache2-secure/conf/httpd.conf:
Can't locate API module structure `digest_module' in file /iweb/s3138130/apache2-secure/modules/mod_auth_digest.so: ld.so.1: httpd: fatal: digest_module: can't find symbol



LoadModule digest_module modules/mod_auth_digest.so

thats inside my httpd.conf


im getting that error after i try to start the server after installing the mod

Samhain13
05-06-2010, 06:12 PM
Just checked the contents of my "auth_digest.load". It says:

LoadModule auth_digest_module /path/to/mod_auth_digest.so

Try changing digest_module to auth_digest_module in your httpd.conf?



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum