View Full Version : Open-window for non-java browsers

Liz Beckman
06-17-2002, 06:48 PM
My open Window javascript will not work gracefully for browsers with Javascript turned off; they click on the link and nothing happens. If Java is on, a new window opens that is sized as specified. To solve this, would I have to have something that detects whether the visitor has Javascript and loads a different page if they do? I wish my open Window script would open a new window of a specific size for Java browsers and would open in the same window for non-Java browsers. Here is the script I am using:

This part goes in the HEAD section:

function MM_openBrWindow(theURL,winName,features) { //v2.0

This is the code around the LINK in the BODY section:

<a href="javascript:;" onClick="MM_openBrWindow('target-page.htm','Window TitleBar Name','toolbar=yes,scrollbars=yes,resizable=yes,width=600,height=400')">

The problem is that users with Java turned off click on the link and go nowhere. Any solutions?

06-17-2002, 07:08 PM
there is one handy dandy tag in html which goes something like this:


this is what the user will see if theydo not have javascript activated


as well in your link you should put somethin like


<a href="something.html" target="_blank"> open window </a>


06-17-2002, 08:37 PM
<a href="target-page.htm" onClick="MM_openBrWindow('target-page.htm','Window TitleBar Name','toolbar=yes,scrollbars=yes,resizable=yes,wi
dth=600,height=400'); return false;" target="_blank">

Note the return false - though I'm not overly sure why, if a
browser can understand the onclick it will NOT do the href, if a
browser either hits an error or simply cannot do js it does the

06-17-2002, 08:41 PM
Aha - I went back and read ALL of your post....

<a href="alternatepage.htm" target="_top" onclick="MM(); return false;">

target="parent" / "self" / "top" / "_new" / "_blank" / "setname"
are all posibilities I think. I never remember which ones have
underscores before them - tinker around til it works :)

Liz Beckman
06-17-2002, 10:24 PM
Perfect! Thanks so much for your replies! The return false worked like a charm... Thanks again!