...

View Full Version : Help, main menu links grow when clicked



Mallard27
12-15-2009, 01:15 PM
I have a website with 3 css files. One is the main and has the header and top navigation formatting in it. The index page has a "parent.css" and that is for the remaining formatting of this page. The about us has a "child.css" and that is for the remaining of the about us. Originally I only had two css files and the common stuff was repeated in both but someone suggested my problem could be conflicting css files so I opted for three. I did try condensing to one but this led to the problem spreading.

link to website: http://www.knoernschilds.com/jnetworking/asecondchance/index.html

Problem. When I click about us, everything works great. But when in about us and clicking home, the menu item expands downward and shifts the menu to the right and sometimes does not work. If you left click and hold, you can see the problem. This problem does not occur on the index.html page.

I have troubleshot this for hours and can't see to figure it out. The only other thought is: since I am in folders far in, should I be specifying the full directory structure for the css or is the way I have it ok (I am grasping for straws here).

Any help would be greatly appreciated!

Thanks,

Mallard27

Rowsdower!
12-15-2009, 01:26 PM
I have a website with 3 css files. One is the main and has the header and top navigation formatting in it. The index page has a "parent.css" and that is for the remaining formatting of this page. The about us has a "child.css" and that is for the remaining of the about us. Originally I only had two css files and the common stuff was repeated in both but someone suggested my problem could be conflicting css files so I opted for three. I did try condensing to one but this led to the problem spreading.

link to website: http://www.knoernschilds.com/jnetworking/asecondchance/index.html

Problem. When I click about us, everything works great. But when in about us and clicking home, the menu item expands downward and shifts the menu to the right and sometimes does not work. If you left click and hold, you can see the problem. This problem does not occur on the index.html page.

I have troubleshot this for hours and can't see to figure it out. The only other thought is: since I am in folders far in, should I be specifying the full directory structure for the css or is the way I have it ok (I am grasping for straws here).

Any help would be greatly appreciated!

Thanks,

Mallard27

This is the source of the problem right here:

#leftmenu a:visited, a:active {
background-color:#4490DB;
border-bottom:2px solid #F3FCEA;
border-color:#F3FCEA;
border-width:2px;
color:#F3FCEA;
display:block;
padding:10px 10px 10px 15px;
text-decoration:none;
}

You can delete the a:active part at the very least. In fact, you can probably delete this entire style section and be fine.

If you don't already have it I highly recommend downloading Firefox and the Firebug plugin. It makes situations like this much easier to diagnose! :thumbsup:

Edit: I should mention that this was in the ascsub.css file (or something like that - I already closed the window so I don't have it in front of me anymore).

Mallard27
12-15-2009, 01:44 PM
Rowsdower,

I deleted this from the ascsub.css. I was still having the problem and then figured out I had an old css file that may have been being referenced but am not sure as I couldn't find the reference but dreamweaver noted the reference when renaming one of the other css files. Long story short, you solved my problem!!!!!!!!!!!!!!!!!!!!!!!! Thank you so much!!!!!!!!!!!!!

#leftmenu a:visited a:active {
background-color: #4490DB;
display: block;
padding-top: 10px;
padding-right: 10px;
padding-bottom: 10px;
padding-left: 15px;
text-decoration: none;
color: #F3FCEA;
border-width: 2px;
border-bottom-style: solid;
border-color: #F3FCEA;
}

Thanks,

Mallard27



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum