...

View Full Version : international characters show on web page



vinoman2
11-17-2009, 01:42 AM
I'm working on a site:
http://emilydickinson.us

It looks fine on Linux or Windows, but on my clients Mac, many of the quotes are international characters like the euro symbol and an "a" with an accent above it. How do I correct this problem in CSS?

oesxyl
11-17-2009, 03:32 AM
I'm working on a site:
http://emilydickinson.us

It looks fine on Linux or Windows, but on my clients Mac, many of the quotes are international characters like the euro symbol and an "a" with an accent above it. How do I correct this problem in CSS?
the page start with:

<div align="right"></div>
then follow doctype and rest of html.
fix markup first:

http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Femilydickinson.us%2F

then check again if the charset is utf-8.

nice site, :)
when I said to check the charset I mean to check the server headers
best regards

vinoman2
11-17-2009, 02:23 PM
Thank you, I deleted the: <div align="right"></div>

what are the server headers?

this is a template that I modified and tried not to change any structure. I don't know why an Apple Mac can't render it properly. It looks good in all other browsers in Linux and Windows!

oesxyl
11-17-2009, 05:59 PM
Thank you, I deleted the: <div align="right"></div>
you are welcome, :)
The problem persist, I assume this is because the page markup is still invalid:

http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Femilydickinson.us%2F


what are the server headers?
when the user request a page the server answer send back a response which start with some 'headers'.


this is a template that I modified and tried not to change any structure. I don't know why an Apple Mac can't render it properly. It looks good in all other browsers in Linux and Windows!
try to fix the validation errors from the link I posted and forget what I'm said about headers. Let's hope that when you finish to fix will work.
Post if you have problems, I will try to help.

best regards

vinoman2
11-17-2009, 07:10 PM
Thanks. I'll work on it soon.

I do have trouble understanding some of the explanations to correct and validate the html. I'll do as much as I can and point out the lines that I can't figure out.

Thanks again. :)

bazz
11-17-2009, 07:16 PM
OK, you need to have a DOCTYPE at the beginning of the page. This tells each browser how the page is supposed to look rather than for it to guess what it is meant to do.

then, your image tags need a fix. all dimensions in the htmlk need to be in quotes like width='200px' and they need a unit of measurement to be there as well (e.g. px).

Also, the img src lines, needs to be closed with /> and not just >

After you have fixed those, I'll take another look and help where needed, if possible.

I agree with oesxyl. Good design and colours.

doctype here - to be put on the first line of your page(s).

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">



what was I thinking?! Your dimensions for width etc should be in the css file and not in the html.

bazz

oesxyl
11-17-2009, 07:32 PM
OK, you need to have a DOCTYPE at the beginning of the page. This tells each browser how the page is supposed to look rather than for it to guess what it is meant to do.

then, your image tags need a fix. all dimensions in the htmlk need to be in quotes like width='200px' and they need a unit of measurement to be there as well (e.g. px).

Also, the img src lines, needs to be closed with /> and not just >

After you have fixed those, I'll take another look and help where needed, if possible.

I agree with oesxyl. Good design and colours.

doctype here - to be put on the first line of your page(s).

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">



what was I thinking?! Your dimensions for width etc should be in the css file and not in the html.

bazz
bazz, op page has a doctype and don't have any problems with css and how it's page look. The only problem is how safari see the page encoding and content type.

best regards

oesxyl
11-17-2009, 07:36 PM
Thanks. I'll work on it soon.

I do have trouble understanding some of the explanations to correct and validate the html. I'll do as much as I can and point out the lines that I can't figure out.

Thanks again. :)
start from top of the page with validation results, fix first, revalidate and repeat untill you finish. Post question when you need, I will try to help.

best regards

bazz
11-17-2009, 08:16 PM
bazz, op page has a doctype and don't have any problems with css and how it's page look. The only problem is how safari see the page encoding and content type.

best regards

I was overriding the doctype to see if the code matched 4.o1 more closely than xtml1.0 strict and I mistook the override for saying one was needed. :(

However, the <br> tags need to be <br /> and my understanding is that the dimensions for images 'should' be in the css.

bazz

oesxyl
11-17-2009, 08:25 PM
I was overriding the doctype to see if the code matched 4.o1 more closely than xtml1.0 strict and I mistook the override for saying one was needed. :(

However, the <br> tags need to be <br /> and my understanding is that the dimensions for images 'should' be in the css.

bazz
I'm agree with you but I already confuse op when I said about headers, :)
We can't know how much op know about all this, it use some software, probably ms Front Page. to build the site. Let's him ask what he need, :)

op need to fix br tags as you said, I hope that my replay don't make him ignore this

best regards

vinoman2
11-18-2009, 03:27 AM
I passed the validation. check it now...
http://emilydickinson.us

I'm going to my friends tonight who has a Mac. I'll check it there.

oesxyl
11-18-2009, 03:41 AM
I passed the validation. check it now...
http://emilydickinson.us

I'm going to my friends tonight who has a Mac. I'll check it there.
how it look now on mac/safari?

sorry, I guess I'm blind, I didn't see your last sentence until now, my question is useless
best regards

oesxyl
11-18-2009, 03:51 AM
I passed the validation. check it now...
http://emilydickinson.us

I'm going to my friends tonight who has a Mac. I'll check it there.
server still not return charset. You can fix this if you edit your htaccess file or server config file and add as default charset utf-8.
This is a link to apache doc for this:

http://httpd.apache.org/docs/2.2/mod/core.html#adddefaultcharset

Let's me know if you fixed or you still have problems.

best regards

vinoman2
11-18-2009, 04:54 AM
I think I solved my problems, My friends Mac had the fonts too big and once we resized them, everything looked OK. My other friend with the international characters has her Default encoding is not set to English, thats' why the euro symbol and the a with the accent above it. I told her to set it to Unicode (UTF-8). That should fix it. And now the page is validated!

Thanks for all the help :)

oesxyl
11-18-2009, 05:04 AM
I think I solved my problems, My friends Mac had the fonts too big and once we resized them, everything looked OK. My other friend with the international characters has her Default encoding is not set to English, thats' why the euro symbol and the a with the accent above it. I told her to set it to Unicode (UTF-8). That should fix it. And now the page is validated!

Thanks for all the help :)
you are welcome and I'm glad you fix it, :) For user setings problems we have no solution, :)
Anyway, this is a good thing, it's more easy to fix problems if the page is validated and if you have time is a good idea to make server to return utf-8 as charset.

best regards

vinoman2
11-18-2009, 05:06 AM
How do I "good idea to make server to return utf-8 as charset." ?

oesxyl
11-18-2009, 05:18 AM
How do I "good idea to make server to return utf-8 as charset." ?
I explain this in:

http://www.codingforums.com/showpost.php?p=889426&postcount=13

best regards



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum