...

View Full Version : body background in external css not working



jfinner1
11-16-2009, 11:55 AM
I just transfered all of my styles to an external CSS document. Everything went well, a few things that I needed to tweak, except for the one thing I thought would go smoothest.


body{
background-color: red;
text-align: center;
}

I have no background color, and my alignment is back to left. Huh? It's a body tag... why wouldn't it work? Any thoughts?

abduraooft
11-16-2009, 12:26 PM
I have no background color, and my alignment is back to left. Huh? It's a body tag... why wouldn't it work? Any thoughts? Please post your entire code or a link to your page would be much better.

jfinner1
11-16-2009, 12:40 PM
Oh yeah, sorry, should have thought of that.

http://jfinner1.co.cc/

The Home, Biography, and Goals pages are done. The Bio page still has the CSS in the page instead of external, so the background works like it's supposed to. And please forgive the absolute corny-ness of it all... The site is for a school project, so each page is pretty much defined for us...

abduraooft
11-16-2009, 12:58 PM
Remove the html tags from your css file

<style type="text/css">
</style>

jfinner1
11-16-2009, 01:07 PM
Wow, I feel really dumb now. Please forgive me, I've only been doing this for 5 weeks, and this is the first time I've taken my styles external. I still feel dumb, lol.

Thank you for clearing that up for me. *blush*



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum