...

View Full Version : removing underline from image link



sixrfan
11-14-2009, 05:20 PM
any idea how i remove the underline from the thumbnail hyperlinks on the right side of my page here: http://www.bandit4x4.com/products/btd0001.html. i'm ok with the underline appearing below the text that says "View Larger" but I need to eliminate the underline from underneath the pics.

???? thanks in advance!

Excavator
11-14-2009, 05:50 PM
This should do it...


#prodtable a:link {
color: #000;
text-decoration: none;
}

sixrfan
11-14-2009, 09:53 PM
no, that did not work. please advise. thanks.

Scriptet
11-14-2009, 10:37 PM
What browser are you reffering to here, because in FireFox the text "View Larger" nor the image above it are underlined..

sixrfan
11-14-2009, 10:46 PM
i'm talking about firefox. attached is an image of the underline i'm referring to.

Apostropartheid
11-14-2009, 11:03 PM
There is no underline. (Firefox 3.5.whatever, Chrome 3)

sixrfan
11-14-2009, 11:13 PM
hmmm. i'm using Firefox 3.0.15.

Apostropartheid
11-14-2009, 11:16 PM
Even IE5.5 and IE6 don't show an underline. Did you hard refresh? (Ctrl-F5)

sixrfan
11-14-2009, 11:31 PM
hard refresh did not seem to clear this issue. :(

Scriptet
11-14-2009, 11:46 PM
Clear the cache, history - Ctrl+Shift+Delete on FireFox, then reload the page.

sixrfan
11-15-2009, 02:59 AM
tried that too. no dice. :confused:

Excavator
11-15-2009, 03:34 AM
http://www.bandit4x4.com/products/btd0001.html has no underlined image here. FF3.5 and IE8.

MattF
11-15-2009, 08:24 PM
Use a:visited too. Btw, get your background colours in order too. Have you tried viewing your pages with images disabled?

sixrfan
11-15-2009, 11:53 PM
you mean #prodtable a:visited? i have that in there already (see below). why would i want to view page with images disabled? and how do i do that? thanks!



#prodtable {
border:1px solid #000;
}
#prodtable td {
border: 1px solid #ccc;
vertical-align: top;
}
#prodtable td.left {
width: 100px;
border: 1px solid #ff8080;
text-align: right;
font-size: 14px;
font-weight: bold;
color: #634432;
}
#prodtable ul {
margin: 0px;
padding: 0px;
}
#prodtable ul li {
margin: 0 0 0 15px;
list-style-position: outside;
list-style-type: square;
}
#prodtable td.middle {
width: 450px;
border: 1px solid #ff8080;
font-size: 14px;
}
#prodtable td.right {
border: 1px solid #ff8080;
width: 160px;
text-align: center;
}
#prodtable a:link {
color: #000000;
text-decoration: none;
}
#prodtable a:visited {
color: #000000;
}
#prodtable a:hover {
color: #666666;
text-decoration: none;
}
#prodtable a img {
text-decoration: none;
}

MattF
11-16-2009, 12:43 AM
you mean #prodtable a:visited? i have that in there already (see below). why would i want to view page with images disabled? and how do i do that? thanks!

Without images, you have black text on a black background. How you disable displaying images is dependant upon your browser.

You need to add the {text-decoration: none;} line to the relevant parts of the CSS, or just add the following at the end of the CSS file.



#prodtable a:link, #prodtable a:visited {
text-decoration: none;
}



Edit: Btw, if it is the a:visited bit causing your underline, you didn't clear your browser cache and history as you were told to, earlier in the thread.

sixrfan
11-30-2009, 02:32 AM
thanks. that does seem to have helped, the underline is gone from the img. but its also go from the word "View Larger" immediately below it. since "View Larger" is a text hyperlink, i'd prefer to keep a underline there. how do i add the underline for the text but keep it removed for the img?



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum