...

View Full Version : validating, error? help please



fabian9931
11-07-2009, 07:30 PM
here is my error below. below the error is my html code. im not understanding the error description. please and thank you.

fabian


Line 98, Column 133: document type does not allow element "a" here; missing one of "object", "span", "bdo", "applet", "iframe", "tt", "i", "b", "u", "s", "strike", "big", "small", "font", "em", "strong", "dfn", "code", "q", "samp", "kbd", "var", "cite", "abbr", "acronym", "sub", "sup", "label", "ins", "del" start-tag
…age('Image7','','aboutamsro.png',1)"><img src="aboutams.png" name="Image7" wi✉
The mentioned element is not allowed to appear in the context in which you've placed it; the other mentioned elements are the only ones that are both allowed there and can contain the element mentioned. This might mean that you need a containing element, or possibly that you've forgotten to close a previous element.

One possible cause for this message is that you have attempted to put a block-level element (such as "<p>" or "<table>") inside an inline element (such as "<a>", "<span>", or "<font>").
Line 98, Column 357: document type does not allow element "a" here; missing one of "object", "span", "bdo", "applet", "iframe", "tt", "i", "b", "u", "s", "strike", "big", "small", "font", "em", "strong", "dfn", "code", "q", "samp", "kbd", "var", "cite", "abbr", "acronym", "sub", "sup", "label", "ins", "del" start-tag
…('Image8','','photographyro.png',1)"><img src="photography.png" name="Image8"✉

Line 98, Column 583: document type does not allow element "a" here; missing one of "object", "span", "bdo", "applet", "iframe", "tt", "i", "b", "u", "s", "strike", "big", "small", "font", "em", "strong", "dfn", "code", "q", "samp", "kbd", "var", "cite", "abbr", "acronym", "sub", "sup", "label", "ins", "del" start-tag
…ge('Image9','','webdesignro.png',1)"><img src="webdesign.png" name="Image9" w✉


Line 98, Column 802: document type does not allow element "a" here; missing one of "object", "span", "bdo", "applet", "iframe", "tt", "i", "b", "u", "s", "strike", "big", "small", "font", "em", "strong", "dfn", "code", "q", "samp", "kbd", "var", "cite", "abbr", "acronym", "sub", "sup", "label", "ins", "del" start-tag
…age('Image10','','contactro.png',1)"><img src="contact.png" name="Image10" wi✉








<div align="center">
<a name="aboutams"> <a href="#aboutams" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image7','','aboutamsro.png',1)"><img src="aboutams.png" name="Image7" width="100" height="28" border="0" id="Image7" alt="aboutams" /></a><a href="#photography" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image8','','photographyro.png',1)"><img src="photography.png" name="Image8" width="100" height="28" border="0" id="Image8" alt="photography" /></a><a href="#webdesign" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image9','','webdesignro.png',1)"><img src="webdesign.png" name="Image9" width="100" height="28" border="0" id="Image9" alt="webdesign" /></a><a href="#contact" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image10','','contactro.png',1)"><img src="contact.png" name="Image10" width="100" height="28" border="0" id="Image10" alt="contact" /></a></a></div>

SB65
11-07-2009, 07:42 PM
You're nesting your <a> elements. Putting your code in a slightly more readable form:


<div align="center">
<a name="aboutams">
<a href="#aboutams" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image7','','aboutamsro.png',1)"><img src="aboutams.png" name="Image7" width="100" height="28" border="0" id="Image7" alt="aboutams" /></a>
<a href="#photography" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image8','','photographyro.png',1)"><img src="photography.png" name="Image8" width="100" height="28" border="0" id="Image8" alt="photography" /></a>
<a href="#webdesign" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image9','','webdesignro.png',1)"><img src="webdesign.png" name="Image9" width="100" height="28" border="0" id="Image9" alt="webdesign" /></a>
<a href="#contact" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image10','','contactro.png',1)"><img src="contact.png" name="Image10" width="100" height="28" border="0" id="Image10" alt="contact" /></a>
</a>
</div>


You've got four links, fine, but these are all wrapped within <a name="aboutams">. Get rid of the code in red.

fabian9931
11-07-2009, 08:02 PM
sb65,

thank you for the reply, there are wrapped in that because the first link "aboutams" supposed to be an anchor. doesnt seem to be working

fabian9931
11-07-2009, 08:04 PM
You're nesting your <a> elements. Putting your code in a slightly more readable form:


<div align="center">
<a name="aboutams">
<a href="#aboutams" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image7','','aboutamsro.png',1)"><img src="aboutams.png" name="Image7" width="100" height="28" border="0" id="Image7" alt="aboutams" /></a>
<a href="#photography" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image8','','photographyro.png',1)"><img src="photography.png" name="Image8" width="100" height="28" border="0" id="Image8" alt="photography" /></a>
<a href="#webdesign" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image9','','webdesignro.png',1)"><img src="webdesign.png" name="Image9" width="100" height="28" border="0" id="Image9" alt="webdesign" /></a>
<a href="#contact" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Image10','','contactro.png',1)"><img src="contact.png" name="Image10" width="100" height="28" border="0" id="Image10" alt="contact" /></a>
</a>
</div>


You've got four links, fine, but these are all wrapped within <a name="aboutams">. Get rid of the code in red.


wait, got it! thanks



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum