View Full Version : Sidebar not showing up in IE7

11-01-2009, 07:23 PM
Hello all.

I recently redesigned my blog (http://www.ottens.co.uk/gatehouse/) but now, I can't get my sidebar to appear in IE 7.

The stylesheet's at http://www.ottens.co.uk/gatehouse/system/themes/Gatehouse/style.css with the sidebar being the "secondary" class.

Any help would be much appreciated! Thanks!

11-01-2009, 07:55 PM
Hello Ottens,
It's there, it's just waaaay over to the right.
Removing position:absolute; from it seems to work but I didn't check that in everything.
See this site about the pitfalls of absolute positioning (http://www.tyssendesign.com.au/articles/css/absolute-positioning-pitfalls/).

If you really must use ap on your sidebar, make the parent container postition:relative; so your sidebar will be positioned from the parent instead of the body of your document.

11-01-2009, 08:04 PM
Oh! I suppose I should get myself a wider screen one of these days...

The problem with the positioning is that when I remove the "absolute" from the sidebar, it disappears in Safari. I've already set "position:relative" on my container (the "page" div), but that doesn't seem to make a difference.

11-01-2009, 08:25 PM
You are using margins there for position. That's not something that goes with ap, positioning with margins is used with floats and elements that are included in the normal flow of the document.

When you ap something, it's taken out of the normal flow... to position it, use pixel measurements from the top left corner of the relative div.
Like this:

.secondary {
font: 12px Trebuchet MS /*'Lucida Grande', Verdana, Arial, Sans-Serif*/;
padding: 5px 0 20px 0;
color: #666;
line-height: 1.3em !important;
overflow: hidden;
position: absolute;
top: 100px;
left: 532px;
I think that will make both IE7 and Safari happy...

Another thing you can fix, I don't see that you're styling .top anywhere...
Just for fun, put a border on that and see where it appears.

.top {
border-bottom: 5px solid #f00;

Not really what you expected, huh?
Now try clearing your floats with this -

.top {
overflow: auto;
border-bottom: 5px solid #f00;

And last, check the links in my sig about validating. There are a few errors there that could easily be fixed.

11-02-2009, 05:26 PM
Why, it worked! Most wonderful. Thanks very much for your help!