...

View Full Version : how to configure FFMPEG On Godaddy Shared Linux Server?



jayminkey
10-05-2009, 07:18 AM
Hi,

I am using php.
I want Cross-Converter which can convert Mp3,Wave,aiff audio files.
I find FFMPEG option with PHP but i don't know how would i configure FFMPEG on my Go daddy Shared Linux Server.

can any one help me in this?

thanks,
jaymin

seco
10-05-2009, 08:23 AM
FFMPEG needs to be installed on root by godaddy, but seeing as its a shared server and its not already installed, i dont think they will install it for you. you will need to find hosting that is ffmpeg ready.

jayminkey
10-15-2009, 10:36 AM
Hi,

thanks for the reply.
yes go daddy not provide any installation support for shared server.

jaymin

jayminkey
11-16-2009, 09:44 AM
Hi,

recently i have moved my hosting to dedicated Linux server.
Now,
can anyone guide me how would i configure FFMPEG on my dedicated Linux server ?

I have ssh root access of my server.

if possible please provide the related detail steps...

Thanks,
jaymin :mad:

seco
11-16-2009, 09:46 AM
we need to know what OS you are running

jayminkey
11-16-2009, 09:49 AM
Operating system Linux 2.6.26.8-57.fc8 (os_FedoraCore 8)

seco
11-16-2009, 10:11 AM
This guide outlines how to install ffmpeg on CentOS, FC8 & Cpanel server.

1. Install the rpm forge repository. For this visit: http://dag.wieers.com/rpm/FAQ.php#B and selct the OS that you're using.

In my case, i run the following for Centos x86_64 5.3:

rpm -Uhv http://apt.sw.be/redhat/el5/en/x86_64/rpmforge/RPMS//rpmforge-release-0.3.6-1.el5.rf.x86_64.rpm

2. Install ffmpeg


yum install ffmpeg mencoder mplayer -y

3. Install ruby through cpanel


/scripts/installruby

4. Install flvtool2:

Visit: http://rubyforge.org/projects/flvtool2/ and download the latest flvtool2 gem then run:


gem install flv*



if this doesnt work let me know.

jayminkey
11-17-2009, 11:48 AM
thanks for the help Seco..

i did try to search for rpm forge repository related to my OS but didn't get exact.
there are lots of option for fedora core 8

could you please help me in this...

my server info....
I am using plesk 8.6.0
- Fedora release 8 (Werewolf)
- 2.6.26.8-57.fc8 (os_FedoraCore 8)

is there anything else required?

using below commands i got this info,

# uname -a

Linux 2.6.26.8-57.fc8 #1 SMP Thu Dec 18 19:19:45 EST 2008 i686 i686 i386 GNU/Linux

# uname -i
i386

# uname -m
i686

i think this is 32 bit kernel


--------------------
one more query :

i have used below command,

cd /root/

wget ftp://fr.rpmfind.net/linux/freshrpms/fedora/linux/8/ffmpeg/ffmpeg-0.4.9-0.10.20080214.fc8.i386.rpm

wget ftp://fr.rpmfind.net/linux/freshrpms/fedora/linux/8/ffmpeg/ffmpeg-devel-0.4.9-0.10.20080214.fc8.i386.rpm

rpm -ivh ffmpeg-0.4.9-0.10.20080214.fc8.i386.rpm

rpm -ivh ffmpeg-devel-0.4.9-0.10.20080214.fc8.i386.rpm

but after running rpm -ivh ffmpeg-0.4.9-0.10.20080214.fc8.i386.rpm commands its says

warning: ffmpeg-0.4.9-0.10.20080214.fc8.i386.rpm: Header V3 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies:
a52dec is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libImlib2.so.1 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libSDL-1.2.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libfaac.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libfaad.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libgsm.so.1 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libmp3lame.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libtheora.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libtheora.so.0(libtheora.so.1.0) is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libvorbis.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libvorbisenc.so.2 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libx264.so.58 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libxvidcore.so.4 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
---------------

So please guide me in this.....

Thanks,
jaymin

jayminkey
11-19-2009, 07:22 AM
Hi,

when i run below command ,

rpm -Uhv ftp://fr.rpmfind.net/linux/freshrpms/fedora/linux/8/ffmpeg/ffmpeg-0.4.9-0.10.20080214.fc8.i386.rpm

i got the below error message,

warning: ffmpeg-0.4.9-0.10.20080214.fc8.i386.rpm: Header V3 DSA signature: NOKEY, key ID e42d547b
error: Failed dependencies:
a52dec is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libImlib2.so.1 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libSDL-1.2.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libfaac.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libfaad.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libgsm.so.1 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libmp3lame.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libtheora.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libtheora.so.0(libtheora.so.1.0) is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libvorbis.so.0 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libvorbisenc.so.2 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libx264.so.58 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386
libxvidcore.so.4 is needed by ffmpeg-0.4.9-0.10.20080214.fc8.i386

can any one help me in this?

thanks,

seco
11-19-2009, 08:15 AM
use the release i sent. fedora and centos are basically the same.

jayminkey
11-20-2009, 08:09 AM
Hi,

thanks for the help.

yes working fine... I have installed rpm ,installed FFMPEG and ruby.

I have some query in FFMPEG installation...

1. After installing ffmpeg mencoder mplayer, ruby

made changes in php.ini file
Add extension=ffmpeg.so in Dynamic Extensions section and restart the web server but still my phpinfo file doesn't show ffmpeg entry.
and how would i use ffmpeg in my php script?
I am using ffmpeg command like this in my php script.

exec('ffmpeg -i xyz.mp3 -ac 1 -ar 48000 -ab 128k -title "New Rock" -comment "New Rocking" -author "Jaymin" -copyright "By jaymin" newtest.wav);


2. where can i upload flvtool2-1.0.6.gem file (in root?)
Also help me in this to install flv tools,

thanks,
jaymin

jayminkey
11-23-2009, 04:58 AM
hey their..

any one who can help me in this... [Operating system Linux 2.6.26.8-57.fc8 (os_FedoraCore 8)]

# rpm -qa | grep ffmpeg
ffmpeg-0.5-3.el5.rf
ffmpeg-libpostproc-0.5-3.el5.rf

ffmpeg-0.5 is installed on my server Also i have make entry of ffmpeg in php.ini file like below

extension=ffmpeg.so in Dynamic Extensions section

Also restart the web server but still my phpinfo file doesn't show ffmpeg entry.

is this right way to add ffmpeg extension in php.ini file?

Please help me in this.

thanks,
jaymin

jayminkey
11-25-2009, 10:29 AM
Hi,

i have installed ffmpeg successfully.

# php -i | grep ffmpeg
ffmpeg
ffmpeg-php version => 0.6.0-svn
ffmpeg-php built on => Nov 24 2009 18:42:08
ffmpeg-php gd support => enabled
ffmpeg libavcodec version => Lavc52.20.0
ffmpeg libavformat version => Lavf52.31.0
ffmpeg swscaler version => SwS0.7.1
ffmpeg.allow_persistent => 0 => 0
ffmpeg.show_warnings => 0 => 0

also add the extention="ffmpeg.so" in php.ini file.

extension_dir = "/usr/lib/php/modules"
extension="ffmpeg.so"

extension is loaded and i have checked ffmpeg entry in phpinfo.php file

when i used ffmpeg in my php script like below,

$audioffmpeg='usr/bin/ffmpeg';
$encode_cmd = "$audioffmpeg -i notify.wav test.mp3";
exec($encode_cmd) or die ("ffmpeg did not work");

it shows me "ffmpeg did not work"

in usr/bin directory there is a entry of ffmpeg so i have used 'usr/bin/ffmpeg' path. Also i have check in usr/local/bin but there is no any single file

i dont know it is path problem or other.

how would i check n set the exact path in php script?
how would i use ffmpeg in my php script?

thanks,
jaymin



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum