...

View Full Version : IE doesn't shows favicon



yaksho
10-01-2009, 07:41 PM
Hello everyone,

I have used following code,
<link rel="shortcut icon" type="image/x-icon" href="http://domain.com/bank/favicon.ico">
Firefox and Crome shows the favicon but IE doesn't. Please help me.

With regards

CaptainB
10-01-2009, 07:54 PM
Try this: http://www.google.com/search?q=IE+doesn%27t+show+favicon&rls=com.microsoft:da&ie=UTF-8&oe=UTF-8&startIndex=&startPage=1

yaksho
10-01-2009, 08:35 PM
Thank you CaptainB but It doesn't work still..

yaksho
10-01-2009, 08:38 PM
You can see my layout design as well as codes at http://uniwebmart.com/bank and you can find my favicon at http://uniwebmart.com/bank/favicon.ico

I can't figure out, where i did wrong..!!

CaptainB
10-01-2009, 08:45 PM
What version of IE are you using?
I'm on IE8 and it shows here..

itproxy
10-01-2009, 09:12 PM
Me too; if I view your site with IE7 (and Firefox3), and add it to my 'favourites', your favicon appears next to the listing, and it shows up in a tab. What's the problem?
I don't think you have to code for a 'favicon' to show up; if it's placed in the root directory of your site (and called 'favicon.ico'), browsers look for and display it automatically!

CaptainB
10-01-2009, 09:18 PM
...Internet Explorer browsers (as of version 6.x) associate favicons with bookmarks. So you must first bookmark the web page. The favicon will appear on the browser address bar and on the Favorites menu, the second time you visit the bookmarked page. If the favicon doesn't appear even after bookmarking and revisiting the web page, restarting the browser may help. ..
source: http://www.htmlkit.com/services/favicon/help/


Most web browsers do not require any HTML to retrieve a favicon that conforms to the de facto file name and type (favicon.ico) located in the web site's docroot. If no favicon link is detected upon HTML page load completion and no previous site visits are recorded in the browser's history, a favicon.ico is requested automatically
Source: http://en.wikipedia.org/wiki/Favicon

yaksho
10-01-2009, 11:05 PM
Thanks for your cordial support CaptinB. My version of IE is 8 and here I still couldn't see the favicon. I've even deleted the cookies and refreshed the site.

CaptainB
10-02-2009, 08:33 AM
Have you tried to delete both the cookies and temporary internet files?
Then close the browser and acces your site again.

Apostropartheid
10-02-2009, 02:41 PM
The odd thing about favicons is that they're incredibly temperamental, especially in IE. I'm afraid you're going to have to put up with it. Eventually, the favicon will appear. Don't let it bother you for now.

yaksho
10-02-2009, 04:38 PM
Yap I deleted it all, but still no any signs... Shall i quit??

CaptainB
10-02-2009, 05:11 PM
Well.. have you tried to view your site on another computer?
I don't think there's too much to do.. it seems like most of us here see it, so as said, don't let it bother you..
You've done it right, so there's really nothing more you can do about it.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum