View Full Version : flash renders differently on mac browsers!!!

08-08-2009, 11:34 PM
HELLO. I hope some genius out there can help my noob-behind...

I built a flash movie for an intro to my website. I verified that everything worked fine in Firefox, then in IE 7. Then last night, when I was TRYING to show off to my friends, I brought it up in Safari on my pals Mac, and the Flash intro was all sorts of screwed up. Everything showed up the same size & all, but the layers were TOTALLY out of place. certain layers were up in the top left corner and, it was embarrassing.lol. So I had them DL Firefox, but it did the same thing, which tells me it is a MACvsPC issue, not the web browser. PLEASE HELP ME, and if you do, dont laugh.lol

my site is cigarcityproductions.com

here is the coding for the page(index.html)...

<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<meta http-equiv="Content-Type" content="text/html; charset=utf-8" />
<title>Welcome to CIGAR CITY </title>
<style type="text/css">
body {
background-color: #000;
<script src="Scripts/swfobject_modified.js" type="text/javascript"></script>

<div align="center">
<table width="803" border="0">
<td width="797"><object classid="clsid27CDB6E-AE6D-11cf-96B8-444553540000" width="800" height="800" id="FlashID" title="Welcome to Cigar City">
<param name="movie" value="ccpintro.swf" />
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="" />
<!-- This param tag prompts users with Flash Player 6.0 r65 and higher to download the latest version of Flash Player. Delete it if you donít want users to see the prompt. -->
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- Next object tag is for non-IE browsers. So hide it from IE using IECC. -->
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="ccpintro.swf" width="800" height="800">
<param name="quality" value="high" />
<param name="wmode" value="opaque" />
<param name="swfversion" value="" />
<param name="expressinstall" value="Scripts/expressInstall.swf" />
<!-- The browser displays the following alternative content for users with Flash Player 6.0 and older. -->
<h4>Content on this page requires a newer version of Adobe Flash Player.</h4>
<p><a href="http://www.adobe.com/go/getflashplayer"><img src="http://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" width="112" height="33" /></a></p>
<!--[if !IE]>-->
<script type="text/javascript">

08-20-2009, 03:39 AM
Everything looks fine for me. (Fine meaning that nothing struck me as odd or out of place.) I'm running Flash Player 10 on an Intel Mac (version 10.5.8) and tried your site with Safari 4 and Firefox 3.5.

Does your friend have the most recent version of Flash Player? I remember when I was a kid I tried viewing some Flash videos made with Flash 8 using Flash Player 7, and everything looked wrong. That might be it, but I'm not knowledgeable enough at the moment to say for sure. (Sorry if I wasn't of any help!:o)