View Full Version : .swf image links

07-09-2009, 01:10 AM
Hi there, i'm fairly new to the world of website-making and am using awardspace as a place to test my sites.

I'm using FTP to put my stuff onto the site and although everything was working offline, when I put my files online they didn't work. I managed to figure out that it was because they were case-sensitive and changed all the folders and filenames accordingly- however, I am trying to embed a .swf file in one page:


And it doesn't seem to be working properly. Pictures from my classifieds/temerity_ii/images folder should be shown, but they're not...

Like the other broken links, they work fine offline but not when I upload them, can anyone tell me what I'm doing wrong or where the dead links are please?

Thanks in advance!

07-12-2009, 09:17 PM
When I looked the first time on a MAC all links seemed to be working. Now, on a PC Windows, the thumbnail images do not show.

Did you do something different in the past few days? If not, is it a PC-specific problem?

Of course you know, the path to the images is important and you have to be careful you're not using a local file:/// path. Are you using ActionScript2 get URL or ActionScript3 to load external files?

I have no clue what the problem might be.

07-12-2009, 11:06 PM
Ah that's intriguing, thank you for looking into this, waxdoc! It never occurred to me to try different OS's.

Yes, perhaps it is something to do with the actionscript. Since I didn't write the .XML or .SWF, it's just a auto-generated html/gallery page/object from Picasa in which I've basically redirected the links and placed it as an object, not as a link to a full-size page (as is default)- I thought it may have confused it.

I tried again on a different free host: www.ssmarine.happyhost.org/temerity_ii (http://www.ssmarine.happyhost.org/temerity_ii) and this seems to work fine, perhaps it is the sort of hosting system that has done this?

I guess it would be useful to find out what caused this, but at least I know now it's not universally wrong. Thanks again for analyzing the page!