...

View Full Version : help with open picture window fever



robcoles
06-29-2009, 04:45 AM
Hi Support
I have had great success using Open Picture Window Fever (DWCS3) on reels page:-
http://www.jcflyfishing.com.au/SHOP/reels.html

But canít for the life of me get it working elsewhere on same site see sample page with 2 images ( http://www.jcflyfishing.com.au/SHOP/rods.html)

SEE BELOW FOR specific script and links


DOESN"T WORK on RODS page??

(2 top rod images 1 in content and 1 in right side panel)


<a class="point" onclick="openPictureWindow_Fever('','../images/rods/large/JCF-FR7-1.jpg','600','350','J Cfly rod','1','1')" > <img src="../images/rods/JCF-FR7-1.jpg" alt="rods" class="float-right" /></a>

ALSO Here doesnít work??

<div id="rightimg"><img class="point" src="../images/rods/side/JCF-FR7-2.jpg" alt="fly rods" onclick="openPictureWindow_Fever('','../images/rods/large/JCF-FR7-2.jpg','600','350','John Coles Fly Fishing Shopping','','')" /></div>



WORKS BEAUTIFULLY on REELS page


http://www.jcflyfishing.com.au/SHOP/reels.html

(All right side images)


<div id="rightimg"><a onclick="openPictureWindow_Fever('','../images/reels/JCF-R1-56-2.jpg','800','569','John Coles Fly Fishing Shopping','','')"><img src="../images/reels/side/JCF-R1-56.jpg" alt="reels" class="point" /><img src="../images/reels/side/JCF-R1-56-1.jpg" alt="reels" class="point" /></a></div>


WHY WHY ?? Iíve been on this for ages and canít understand WHY???

Hope you can enlighten me
Cheers Rob

Old Pedant
06-29-2009, 07:02 AM
You have javascript errors even on the REELS page.

You have AT LEAST one missing } character in that ".js" file and apparently also a misnamed object.

Use a DEBUGGER to find these bugs.

Even MS Script debugger found the two I mentioned. FireBug with FireFox would find those and probably more.

As for the RODS page, looks like you have a mangled line of code. The debugger reports a problem at line 13.

<!--
//
Hide script from older browsers // script by http://www.jcflfishing.com.au var urlAddress
= "http://www.jcflyfishing.com.au/shop.html"; var pageName = "JohnColesFlyFishing"; function addToFavorites() { if (window.external)

I think you are missing a line break after the ".com.au" and before the "var", but in any case you have an error there. Again, use a debugger.

And not to ask a dumbass question, but....*WHAT* "older browsers"???? The only "older browsers" that can't handle JS are MSIE 3 and its ilk. You know, vintage 1998 or so. The need for the silly <!--// and //--> disappeared about year 2000 or at the latest 2001. Time to move into the 21st century.

robcoles
06-30-2009, 12:10 AM
Thankyou I was unaware of debugger and am not a coder so this will be a great help.
The old browser script just appeared on its own ... it's all a mystery?
regards Rob

Old Pedant
06-30-2009, 02:47 AM
LOL! Been there, done that.

Okay, if that doesn't fix it, let us know.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum