View Full Version : PLease help me understand the VALIDATOR results

05-12-2009, 11:45 PM
I understand the first one about the form, but the others seem to be errors with my closing tags.

www.vciparts.com (http://validator.w3.org/check?verbose=1&uri=http%3A%2F%2Fwww.vciparts.com%2Findex.php#result)

I did find the missing </ul> tag, and fixed it, but it still looks like it's not quite making it.

Thanks in advance.
~ Mo

NOTE: my cade is modular, so the best way to view it all assembled is just to view the source.

05-12-2009, 11:46 PM
I suppose you forgot to attach your link?

05-13-2009, 12:02 AM

I caught that just after I hit the button.
The post has been edited.

Thanks again.

05-13-2009, 12:56 AM
OK, the first three errors are pretty simple:

The name attribute is not allowed except on form controls (i. e. inputs and textareas). You should give the form an ID and address it in JavaScript with forms['YourIDhere']
Input elements must not be direct children of a form. You have to put them in another block level elements such as a fieldset (which you can hide with CSS if necessary) or a div or whatever.

Then you have a list with missing closing tag (ul “primaryNav” inside the div “mainNav”). The rest is gonna be fixed automatically if you close that list.

05-13-2009, 01:26 AM
Thanks for the fieldset suggestion. I didn't find instructions for that anywhere (even w3scools examples the input as a child of form), but that definitely took care of it.

As for the the missing </ul> tag, I'm going to have to post in the PHP group or something.
My constant is defined with the closing tag, but it's just getting dropped for some reason.

Once again, thanks-a-bunch.
~ Mo