...

View Full Version : How can i stop the browser from adding any whitespace at all?



beedie
05-12-2009, 09:14 PM
i have an td that is adding some space after and below the element in it.
Is there a way to prevent this?
I have set all the widths and heights correctly but it doesn't help. the extra space is still being added.

adios
05-12-2009, 09:20 PM
Compress your HTML source. Get rid of all whitespace in & around that element, including linefeeds. Browsers are supposed to ignore source code formatting, but don't bet the house on it.

If that doesn't fix it, post the relevant code here (wth full image urls if they're involved).

luckyfella73
05-13-2009, 11:15 AM
Maybe you just have to resset margin and padding

css:
td {margin:0px;padding:0px;}


yahoo provides a "reset.css" which is very helpful to
get your site crossbrowser conform by resetting all
elements.

effpeetee
05-13-2009, 11:41 AM
It is a good idea to start your css with this universal reset.

*{
margin:0;
Padding:0;
}

Some browsers do not default to zero and this takes care of that. It resets all padding and margins to zero whether tables or regular css.
It may mean that you need to adjust your existing settings a little.

Also you should show us your cade and tell us which browser you find troublesome.

Perhaps this may help you. (http://www.hotdesign.com/seybold/)

I show it ot you as if I don't, somebody else will.

Frank



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum