...

View Full Version : Site not compatible in IE :(



nobackseat88
05-08-2009, 01:51 AM
Someone please help me? My site isn't compatible in IE, and I have tried multiple codes to to fix, all fail.

Somebody lead me in the right direction, or at least advise me of which piece of code is making the problem. :confused:

[Site Removed]

drhowarddrfine
05-08-2009, 04:25 AM
The head of your page is missing a doctype. Without one, IE makes no attempt to perform like other more modern browsers. Use HTML4.01 strict.

nobackseat88
05-08-2009, 09:39 PM
Which doctype do you recommend?

nobackseat88
05-08-2009, 09:51 PM
These help very much, but none of them fully fix the site. :(

<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Transitional//EN"
"http://www.w3.org/TR/html4/loose.dtd">


<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01 Frameset//EN"
"http://www.w3.org/TR/html4/frameset.dtd">

thecaligarmo
05-08-2009, 10:51 PM
What specifically is not working? Is it the backgrounds? or the extra space on the bottom?

websteralex
05-08-2009, 11:13 PM
use this doctype : <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN"
"http://www.w3.org/TR/html4/strict.dtd">

and

try validating the page while your at it :D

nobackseat88
05-08-2009, 11:44 PM
Trust me, I've validated the page innumerable times before I asked this. :(

nobackseat88
05-08-2009, 11:45 PM
What's not working?

Well there are these rounded corner boxes...

That were originally on the side of the page...

They were like the side bar, but seperated by like modules.

They don't show in IE.

They show in FF, but after I messed around with the coding, they all show up in one straight column on the left with no text. :(

nobackseat88
05-09-2009, 01:48 AM
I've finally got it!

*hugs dreamweaver*



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum