...

View Full Version : Can't figure it out?



liquidkrep
04-09-2009, 12:06 AM
I'm having an issue with an index page, on this page, http://www.santanbrewing.com , in internet explorer it does not line up correctly. In IE on the index page, there are two different rotating javascript slideshows that do not center like the other content on the page. If you look at the site on firefox, it looks correct but in IE, it doesn't. Any idea help is much appreciated.

Thanks in advance.

Excavator
04-09-2009, 12:57 AM
Hello liquidkrep,
Does this fix it for you?

#content {
position: relative;
padding-bottom: 34px;
}


That is a difficult site to work on/debug what with all the inline styles, absolute positioning and tables. A whole lot of code for not much content.
See the links in my sig below.
Also have a look at this one - http://www.tyssendesign.com.au/articles/css/absolute-positioning-pitfalls/

liquidkrep
04-09-2009, 02:38 AM
it did not work. I'm not sure what you are talking regarding absolute positioning? Also, I have made a separate "test" page. Check it out here;

http://www.santanbrewing.com/test.html

Excavator
04-09-2009, 03:10 AM
In that demo, you can put a width on your #content to hold things together.
Like this -

#content {
width: 1024px;
margin: 0 auto;
padding-bottom: 34px;
background: #000; /*for testing only*/
}

liquidkrep
04-09-2009, 03:53 AM
thanks but I figured it out. The table width needed to be 100% and not a fixed width.

Excavator
04-09-2009, 11:00 AM
Why tables for layout is stupid (http://www.hotdesign.com/seybold/)



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum