...

View Full Version : remote vs local xml on browser



bctrail
04-06-2009, 01:31 AM
I have a 30K xml file and its DTD, successfully passed a validating parser. I have written a xsl file which transforms it to HTML. I am running mozilla 3.0 on Linux. When I point the browser to the xml file located on my local hard drive, I get the HTML page I expect. When I put the same files on my ISP's web server, and access the file, I get the raw xml file, without transformation. How do I get the XSL to kick in on the server? I have tried pointing to "file://.......xml" instead of "http://........xml", but to no avail.

Any comments, ideas, and/or suggestions would be greatly appreciated.

bctrail

oesxyl
04-06-2009, 03:11 AM
I have a 30K xml file and its DTD, successfully passed a validating parser. I have written a xsl file which transforms it to HTML. I am running mozilla 3.0 on Linux. When I point the browser to the xml file located on my local hard drive, I get the HTML page I expect. When I put the same files on my ISP's web server, and access the file, I get the raw xml file, without transformation. How do I get the XSL to kick in on the server? I have tried pointing to "file://.......xml" instead of "http://........xml", but to no avail.

Any comments, ideas, and/or suggestions would be greatly appreciated.

bctrail


<?xml-stylesheet type="text/xsl" href="yourpath"?>

yourpath must be the relative path between your xml file and xslt file.

I hope this help you.

best regards

bctrail
04-06-2009, 02:11 PM
Thanks for the reply. I have checked that out, and it seems to be in order. The relative path set up is the same, both locally and remotely, since both files are "together" in both locations. I'm wondering if I need to do something different when I make the browser request.

BCT

oesxyl
04-06-2009, 02:14 PM
Thanks for the reply. I have checked that out, and it seems to be in order. The relative path set up is the same, both locally and remotely, since both files are "together" in both locations. I'm wondering if I need to do something different when I make the browser request.

BCT
can you post a link here?

best regards

bctrail
04-06-2009, 03:25 PM
Thank you again.

Well, this gets interestinger and interestinger. I just went to my handy public library and tried using their windows machines. It seems if I use Firefox on windows, I get the results described previously. HOWEVER, if I use Internet Explorer, everything is peachy keen, and the XSL executes as expected. So I guess I'll have to dig in to FireFox a bit.

EDIT:

I would rather not post the link here, but I would be glad to send it to you by private message. Want me to try that?

EDIT #2:

After browsing the FireFox/Moilla web site, it appears that several bugs have been reported about similar sorts of problems. For the moment, the workaround would seem to be to use IE when accessing remotely.


BCT



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum