...

View Full Version : Ever see this error message on phpdev?



gorilla1
03-14-2003, 03:07 AM
I have been running phpdev423 fine for many months on my w98 system - never the least problem. In the last few days I installed w2k on my system as a dual boot with w98. Now when I bring it up on the w98 side, I get the following message:

C:\phpdev\apache>apache.exe -k start
Failed loading C:\phpdev\php\extensions\ZendOptimizer.dll
PHP Warning: Unable to load dynamic library 'C:\phpdev\php\extensions/php_gd.dl
l' - A device attached to the system is not functioning.

On the w2k side, I loaded phpdev423 (upgrade at last) [21-10-2002], and it runs fine.. Does having phpdev on the two systems somehow cause a problem? (The two operating systems are on separate hard drives - w98 is formatted fat32, w2k is formated for the nt file system (ntfs?). Is there some remedy for this

One more problem.. On the w2k side, apache comes seeing the w98 drive (C), rather than the w2k drive (D), even though the phpdev start file references the D drive all the way through.
G

firepages
03-15-2003, 02:05 PM
Hi, I have not seen that particular error , but I share the one installation accross the different partitions, i.e. I have XP ,2K & .NET server on 3 partitions on my test comp.

I installed phpdev etc to the 2K partition as 2k seems the fastest of the 3 .
So once once you have it working on 1 partiton, reboot into 98 and copy the php.ini & my.cnf files from the 2K partition to the win98 drive.

then write a batch file or whatever to start apache & mysql from win98, win 98 does not give a hoot where they are actually located.


just thinking ... can win98 on FAT32 access a NTFS drive ? I dont think it can, errr then that wont work :(

gorilla1
03-15-2003, 07:02 PM
Thanks. Right, w98 cant see ntfs. Which is why the phpdeve failure on the w98 side is all the more suprising. Guess I will just re-install it.
G



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum