...

View Full Version : Need help with code problems (background images)



mnkyman
04-04-2009, 08:28 AM
Here is the site: www.TeamRowdyRiders.com

Notice if you view the page in firefox it looks fine, however when you view it in internet explorer, there seems to be a problem with the text boxes (text boxes as in the ones with dates) being set as background...also, i've noticed there is a larger space in between the sponsor box and the first box in IE compared to firefox.

any help will be much appreciated, thanks

abduraooft
04-04-2009, 08:53 AM
I haven't checked your website, but I'd recommend you to validate and fix all errors in your markup, see http://validator.w3.org/check?uri=http%3A%2F%2Fwww.teamrowdyriders.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

You need a valid doctype (http://www.alistapart.com/articles/doctype) at the top of your document.

kitchen87
04-04-2009, 09:01 AM
I also has the same problem in one of my site. But I don't know what is the solution. Anyone, who knows how to fix this problem..

kitchen87
04-04-2009, 09:05 AM
I haven't checked your website, but I'd recommend you to validate and fix all errors in your markup, see http://validator.w3.org/check?uri=http%3A%2F%2Fwww.teamrowdyriders.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

You need a valid doctype (http://www.alistapart.com/articles/doctype) at the top of your document.

Hi abduraooft, thanks for sharing this tool. What I know, this tool is to check the error coding in our site. i have been use it. But this tool can't fix this problem..

p/s : sorry if I wrong.

abduraooft
04-04-2009, 09:12 AM
Hi abduraooft, thanks for sharing this tool. What I know, this tool is to check the error coding in our site. i have been use it. But this tool can't fix this problem..
Yes, you're right. It's a validation tool, and it will give some good hints on how to rectify the issue.

mnkyman
04-04-2009, 09:17 AM
I haven't checked your website, but I'd recommend you to validate and fix all errors in your markup, see http://validator.w3.org/check?uri=http%3A%2F%2Fwww.teamrowdyriders.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

You need a valid doctype (http://www.alistapart.com/articles/doctype) at the top of your document.

thanks for the links to the validator....i read the article as well, however i'm still unsure on which head tag to use...i tried a couple of them posted on the website, however this would only create more errors on the validator and screw up the look of the site...

also, the rest of the warnings don't make sense (to me)...they are all valid code...but then again it could all be due to the head tag.

abduraooft
04-04-2009, 09:21 AM
, however this would only create more errors on the validator and screw up the look of the site... If you are talking about the validator, it won't ever mess your website. Rather, it'll show you the errors in your markup correctly, and this will help you to solve your issue. There is no shortcut.

mnkyman
04-04-2009, 09:26 AM
If you are talking about the validator, it won't ever mess your website. Rather, it'll show you the errors in your markup correctly, and this will help you to solve your issue. There is no shortcut.

no, i'm speaking about the specific head tags in the article you posted...i tried adding some but it kinda messed up the site, as in...im not sure what head tag to add.

edit: found a head that I use to use on my old sites and added that...seemed to remove that error, however the other errors still exist and say that i should use a "translational" head tag, which i am...

the updated page is posted at: www.teamrowdyriders.com/index22222.htm

abduraooft
04-04-2009, 09:34 AM
<td> <img src="images/spacer.gif" width="103" height="1" alt=""></td>
<td> <img src="images/spacer.gif" width="114" height="1" alt=""></td>

<td> <img src="images/spacer.gif" width="38" height="1" alt=""></td>
<td> <img src="images/spacer.gif" width="79" height="1" alt=""></td>
<td> <img src="images/spacer.gif" width="117" height="1" alt=""></td>
<td> <img src="images/spacer.gif" width="113" height="1" alt=""></td>
<td> <img src="images/spacer.gif" width="18" height="1" alt=""></td>
<td> <img src="images/spacer.gif" width="99" height="1" alt=""></td>

<td> <img src="images/spacer.gif" width="114" height="1" alt=""></td>
<td> <img src="images/spacer.gif" width="9" height="1" alt=""></td>
<td> <img src="images/spacer.gif" width="75" height="1" alt=""></td>
<td> <img src="images/spacer.gif" width="21" height="1" alt=""></td>
<td></td> I should have checked your markup, before trying to validate. Do you know why tables for layout is stupid (http://www.hotdesign.com/seybold/)?
I'd recommend you to follow a table less CSS based layout like http://bonrouge.com/2c-hf-fixed.php

mnkyman
04-04-2009, 09:45 AM
I should have checked your markup, before trying to validate. Do you know why tables for layout is stupid (http://www.hotdesign.com/seybold/)?
I'd recommend you to follow a table less CSS based layout like http://bonrouge.com/2c-hf-fixed.php

i learned how to code a long time ago lol...and have forgotten much of that as well, so I used photoshop to chop up the template and place it in a table to begin with...

I guess this site's coding was doomed from the beginning in today's standards...



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum