...

View Full Version : Wierd Problem About My Links



Mccall101
03-30-2009, 02:05 PM
On my computer my links are nuerochrome like they should be. In IE they are Nuerochrome. but on this school computer, my links are in times new roman. Whats wrong and how do I fix it.

Btw on my comp and the school comp im using firefox

Also my footer is detached


http://www.skodesigns.com

Forgot to include it

nick1988
03-30-2009, 02:54 PM
The computer you are using at school doesn't have the neurochrome font. Therefore it can only render it in something it has got. This also means that the majority of visitors to your site will also be lacking the font.

If you want your navigation to be in the neurochrome font, the easiest way (if not the only way?) is to make your navigation use images with the font.

The link below lists most websafe fonts. You can also specify more than one font in your css. That way if the user doesn't have the first font you have specified it will attempt to render the next.

http://www.wpdfd.com/issues/87/knowing_about_web_safe_fonts/

Also, you should validate your mark-up:
http://validator.w3.org/check?uri=http%3A%2F%2Fwww.skodesigns.com&charset=%28detect+automatically%29&doctype=Inline&group=0

Mccall101
03-30-2009, 02:59 PM
how do I fix my footer being detached?

Mccall101
03-30-2009, 03:05 PM
Also when I change my font, my links shoot up in the air.

nick1988
03-30-2009, 03:05 PM
how do I fix my footer being detached?

Do you mean the black strip not touching the bottom, leaving half your footer text over the background colour?


#footer{
position: center;
width: 1023px;
height: 22px;
background-image: url(http://www.skodesigns.com/images/SKODesigns2_07.png);
background-repeat: repeat-y;
color: white;
}

Adding a background-repeat: repeat-y; fixes that.

Mccall101
03-30-2009, 03:10 PM
Do you mean the black strip not touching the bottom, leaving half your footer text over the background colour?


#footer{
position: center;
width: 1023px;
height: 22px;
background-image: url(http://www.skodesigns.com/images/SKODesigns2_07.png);
background-repeat: repeat-y;
color: white;
}

Adding a background-repeat: repeat-y; fixes that.

Well the black strip with the copyright info is detached from my content background image

Excavator
03-30-2009, 04:41 PM
Well the black strip with the copyright info is detached from my content background image

An UNcollapsing margin (http://nopeople.com/CSS/uncollapsing-margin/index.html)is causing that.

It's being caused by the 10px top margin on your p. Edit this to see -
p {
margin: 0 10px;
text-align: left;
color: #fff;
text-indent: 10px;
}

You probably want to keep 10px top margin on your p tag in #content so, to fix it, you can either

- put a top border on #footer like my example shows
- use padding instead of top margin on your p tag in #footer
or this-

#content {
width: 1023px;
height: 620px;
background:url(images/SKODesigns2_05.png) no-repeat;
text-align: left;
}

#footer{
width: 1023px;
height: 22px;
text-height: 22px;
text-align: center;
background: url(images/SKODesigns2_07.png) repeat-y;
color:#fff;
}

#content p {
margin: 10px;
text-align: left;
color: #fff;
text-indent: 10px;
}



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum