...

View Full Version : Issues running .php files in subfolders on WebProject? [PHP & IIS7]



Shaitan00
03-29-2009, 04:47 AM
I'm running IIS7 as a webserver for my PHP project, initially the project had a single index.php file (in the root of the web space) and everything was working fine.

Now I've important all these new PHP files (into the root) and created subfolder (/includes/) which contain a bunch of .PHP scripts which I "include" from my main index.php, oddly enough these don't seem to run...

I've asked around and a bunch of people mentioned setting "Execute Permissions is set to Scripts Only" in the Home Directory Tab... I beleive this is for an older version of IIS because with IIS7 I can't find anything like that ...

So, two quick questions
a) any clues what it could be? aside from permissions (which I find odd, I would have assumed any subdirectories to the webspace would be ok)
b) how do I add "scripts only" execute permissions?

Is there a way to debug/test this?
(note - I am running Microsoft Windows Vista 64b)

Any help/hints or ideas would be much appreciated...
Thanks,

ShaneC
03-29-2009, 05:24 AM
Unfortunately I'm not very familiar with IIS so I personally won't be able to help you out there, hopefully someone else has the answer. If you're interested in just developing locally and you need a server I highly suggest WAMP Server (http://wampserver.com/en). This will install Apache, PHP, and MySQL on your computer and is a great testing environment.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum