...

View Full Version : Flash banner works in Firefox but not in IE



Crystal Clear
03-20-2009, 02:49 PM
Hi everyone.

I'm new to flash and trying to embed a flash banner on my site. I have found that it works in Firefox but (surprise surprise) not in IE. In IE it just shows a white space!!

The .swf code is as follows:

<OBJECT classid="clsid: D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0"
WIDTH="468" HEIGHT="60" id="bottomflashbanner3"><PARAM NAME=movie VALUE="myFlashMovie.swf">
<PARAM NAME=quality VALUE=high><PARAM NAME=bgcolor
VALUE=#FFFFFF><EMBED src="images/bottomflashbanner3.swf"
quality=high bgcolor=#FFFFFF WIDTH="468" HEIGHT="60"
NAME="bottomflashbanner3" ALIGN="" TYPE="application/x-shockwave-flash"
PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED></OBJECT>


To give you an idea of what's happening I have uploaded it onto a sub page of my site which can be viewed at http://www.crystalcleardubs.com/alias.html . It's the banner at the bottom of the page.

Any ideas?

Thanks

Andy

abduraooft
03-20-2009, 02:59 PM
<OBJECT classid="clsid: D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=8,0,0,0"
WIDTH="468" HEIGHT="60" id="bottomflashbanner3"><PARAM NAME=movie VALUE="myFlashMovie.swf">
<PARAM NAME=quality VALUE=high><PARAM NAME=bgcolor
VALUE=#FFFFFF><EMBED src="images/bottomflashbanner3.swf"
quality=high bgcolor=#FFFFFF WIDTH="468" HEIGHT="60"
NAME="bottomflashbanner3" ALIGN="" TYPE="application/x-shockwave-flash"
PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer"></EMBED></OBJECT>
Any clues?
btw, I'd recommend you to use swfobject (http://code.google.com/p/swfobject/)

Crystal Clear
03-20-2009, 03:17 PM
thanks mate, it was the myflashmovie bit that needed changing....works now in IE!



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum