...

View Full Version : 1 problem with suckerfish menu in ie6



cactux
03-06-2009, 08:55 PM
Hello,

After reading the several threads here about problems with sucker fish menu, the problem I have is not listed.
Here is my problem: there's one item in the CSS which I can not make specific to the menu, and it blocks the correct display of classic lists which are in my page.
Let's have a look at the menu which works:
http://www.cactuspro.com/menu_test.php
But at the bottom of the page, there's a 2 level list, the second level is hidden.

The problem come from this in the css:

ul li ul {
display: none;
}
If I add div#cf_div_menu_haut in front of it, the menu does not work anymore in internet explore 6 & 7, although it keeps working in Firefox 3 (Linux and windows) and Konqueror.

Do you know how I could solve that?

Thanks a lot.

Camron467
03-07-2009, 01:31 AM
I'm not sure what you are asking, I was looking at it and don't see any need in having display: none; it seems to work fine without it.

Please explain what you are trying to do, and maybe I can help you more.

cactux
03-07-2009, 09:50 AM
I'm not sure what you are asking, I was looking at it and don't see any need in having display: none; it seems to work fine without it.

Without this, internet explorer will display all the content of the submenus below it. (but it works fine in Firefox).


Please explain what you are trying to do, and maybe I can help you more.

As the menu is built with lists (UL LI) and CSS, I want the CSS applied ONLY to this menu, not other lists in the page.

Thanks for your help :)



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum