...

View Full Version : DIV heights different on Mac & PC, but the same in browsers.



UtterBen
02-27-2009, 11:57 AM
Not to be too confusing, but I have a website that appears the same in IE and FF on a PC plus Safari on a Mac, but different in FF on a Mac.

On a PC (and Safari on Mac) the site appears correct.
On a Mac, in FF the site is misaligned.

The page in question is http://www.uttermedia.net/page_fire

The bottom of the flash gallery on the page SHOULD line up perfectly with the bottom of the 'HOME PHOTO DESIGN IMAGE' links.

On Mac, the flash gallery appears about 49px too high.

The site is made of two basic divs.

Any help or pointers would be much appreciated, this has been bugging me for weeks, and I can't seem to find the problem! :eek:

VIPStephan
02-27-2009, 03:49 PM
It looks like this in my Firefox (latest version on Mac):

http://codingforums.com/attachment.php?attachmentid=7185&stc=1&d=1235749642

Note the yellow background at the bottom. This is because my default browser background is not white and you forgot to specify a color explicitly.

Excavator
02-27-2009, 03:51 PM
Hello UtterBen,
I have no MAC machine to test on so I can't see this but...
if you put a background color on your right div, #text1 like this:

#text {
float: right;
margin: 72px 10px 0 0;
width: 355px;
height: 579px;
font: 10px "Verdana";
color: #404040;
line-height: 13px;
background: #f00;
}
You can see your not wrapping all your content.
Remove the height, like this, and see what happens:

#text {
float: right;
margin: 72px 10px 0 0;
width: 355px;
/*height: 579px;*/
font: 10px "Verdana";
color: #404040;
line-height: 13px;
background: #f00;
}

Same thing is happening on your #image too.
Does that help?

UtterBen
02-27-2009, 04:04 PM
Hey guys,

Many thanks for your help. I managed to fix the problem just after I made this post (hence the screenshot looking good). It turned out to be line-height. Needed to include it in CSS for all my divs. Now the entire site looks identical in all browsers.:rolleyes:

Excavator...I wasn't aware of the wrapping issue, so kudos for spotting that! Thanks.

Excavator
02-27-2009, 04:38 PM
Excavator...I wasn't aware of the wrapping issue, so kudos for spotting that! Thanks.

Actually, VIPStephan got it 2 minutes before I did, hehe.

VIPStephan
02-27-2009, 05:05 PM
You still didn’t specify that your page background color should be white.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum