...

View Full Version : drop down menu appearing behind flash



ksanjanadevi
02-19-2009, 04:59 AM
Drop down menu is appearing behind the flash and how do I get rid of this?
I used z-index in menu its not working and used wmode=transparent and opaque its not working..
Any solutions>


<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"
WIDTH="100" HEIGHT="100" id="myMovieName"><PARAM NAME=movie VALUE="http://www.youtube.com/v/vpWEuOJQYYs&amp;hl=en"><PARAM NAME=quality VALUE=high><PARAM NAME=bgcolor VALUE=#FFFFFF>
<param name="wmode" value="transparent" /><param name="quality" value="high">
<param name="embed" value="transparent"><br>
<param name="menu" value="false"><EMBED src="http://www.youtube.com/v/vpWEuOJQYYs&amp;hl=en" quality=high bgcolor=#FFFFFF WIDTH="100" HEIGHT="100" NAME="myMovieName" ALIGN="" TYPE="application/x-shockwave-flash"
PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer" wmode="transparent" menu="false"></EMBED></OBJECT>

abduraooft
02-19-2009, 07:07 AM
Can we have a link to your page(or a sample one)?

ksanjanadevi
02-19-2009, 07:46 AM
I have given my full code and the flash object can be taken from health enclave .com (I dont want to give url, so gave the name of the site).. I could not give the zip file since it exceeds 50.0KB size..




<html>
<head>
<link rel="stylesheet" href="style-home.css" type="text/css" />
<style type="text/css">
#zUL,#zUL ul {padding:0;margin:0;position:relative;z-index:500;}
#zUL li ul a {margin-left:1em}
#zUL li {
float:left;
width:9em;
position:relative;
list-style-type:none;
font-weight:600;
}

#zUL li ul {
visibility:hidden;
position:absolute;
}

#zUL li:hover ul {
visibility:visible;
background-color:#efefef;
z-index:10;

}

</style>
</head>
<body>
<div>
<ul id="zUL">
<li><a href="#">1st Set of Links</a>
<ul>
<li><a href="Link 11">Link 11</a></li>
<li><a href="Link 11">Link 12</a></li>
<li><a href="Link 11">Link 13</a></li>
<li><a href="Link 11">Link 14</a></li>
<li><a href="Link 11">Link 15</a></li>
<li><a href="Link 11">Link 16</a></li>
<li><a href="Link 11">Link 17</a></li>
<li><a href="Link 11">Link 18</a></li>
<li><a href="Link 11">Link 19</a></li>
<li><a href="Link 11">Link 20</a></li>
<li><a href="Link 11">Link 16</a></li>
<li><a href="Link 11">Link 17</a></li>
<li><a href="Link 11">Link 18</a></li>
<li><a href="Link 11">Link 19</a></li>
<li><a href="Link 11">Link 20</a></li>
</ul>
</li>
</ul>
</div>
<br/><br/><br/>

<OBJECT classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000"
codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"
WIDTH="100" HEIGHT="100" id="myMovieName"><PARAM NAME=movie VALUE="http://www.youtube.com/v/vpWEuOJQYYs&amp;hl=en">
<PARAM NAME=quality VALUE=high>
<PARAM NAME=bgcolor VALUE=#FFFFFF>
<param name="wmode" value="transparent" /><param name="quality" value="high">
<param name="embed" value="transparent"><br>
<param name="wmode" value="transparent">
<param name="menu" value="false">
<EMBED src="http://www.youtube.com/v/vpWEuOJQYYs&amp;hl=en" quality=high bgcolor=#FFFFFF WIDTH="100" HEIGHT="100" NAME="myMovieName" ALIGN="" TYPE="application/x-shockwave-flash"
PLUGINSPAGE="http://www.macromedia.com/go/getflashplayer" wmode="opaque" menu="false">
</EMBED>
</OBJECT>
</div>

</body>
</html>

abduraooft
02-19-2009, 07:59 AM
It's OK for me in FF2. Which is your browser?
btw, use wmode="transparent" instead of opaque.

ksanjanadevi
02-19-2009, 10:40 AM
hi thanks it worked.. This works in Windows platform Firefox.
But I am using Linux platform Firefox 2.0



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum