...

View Full Version : Menu does not work in IE



neonflorida
11-17-2008, 09:26 PM
Hi and sorry about another IE question.

I have created a menu to use with a site and it works and looks just great and how we want in Safari, firefox,chrome and opera. When we preview in IE it does not show as how it should. We get text but no CSS style to it and the text is not aligned anymore. Here is my CSS code for the Menu :

#main_menu {
width:730px;
padding-top:2px;
padding-bottom:2px;
background-color:#383429;
text-align:left;
color:#FFFFFF;
margin-bottom:5px;
}

#main_menu a {
font-family:Verdana, Arial, Helvetica, sans-serif;
font-size:60%;
font-weight:bold;
text-transform:uppercase;
color:#FFFFFF;
text-decoration:none;
padding-left:5px;
padding-right:5px;
padding-top:12px !important;
padding-top:13px;
padding-bottom:11px;
margin-left:0px !important;
margin-left:0px;
}

#main_menu a:hover {
background-color:#3F4A3E;
background-image: url("link.jpg");

}

#main_menu .aactive {
background-color:#3F4A3E;
background-image: url("link.jpg");

and here is my HTML :

<class id="main_menu">
<a href="" class="aactive">About Us</a> <a href="">HR Solutions</a> <a href="">
Conference &amp; Seminars</a> <a href="">Talent Development Institue</a> <a href="">
Career Coaching</a><a href="">Keynotes</a></class>

My class id is within an actual Div which is for my main content box. I am baffled and have searched all over. Would conditional comments be required for this?.

I checked my CSS and XHTML and they validate perfect. I am lost.

Apostropartheid
11-17-2008, 10:58 PM
You haven't checked your XHTML properly. There is no class tag in the recommendations. Browsers generally don't apply styles to unrecognized elements, so this is probably part of your problem.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum