...

View Full Version : Mouse Over



Bick
07-06-2002, 04:39 PM
I'm having real problems getting my mouse over code to work. Could someone please help me out below is a sample of the code that i'm working on..
Only the first link is the one i'm working on now but i keep getting errors..
I would like the rest of the links to go along the same lines as the first..

<html>

<head>
<meta http-equiv="Content-Language" content="en-us">
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<title>Menu</title>
<base target="main">
<meta name="Microsoft Border" content="none, default">

</head>

<body background="images/greek3_copy.jpg" onload="setRollover()">

<p>

<A HREF="faq.html" onMouseOver="document.images['home'].src='images/home_on.gif'" onMouseOut="document.images['home'].src='images/home_off.gif'"><IMG SRC="images/home.gif" width="167" height="26" BORDER="0" NAME="home"></a></p>
<p style="line-height: 73%"><a href="actives.htm" target="parent"><img border="0" src="images/brothers_off.gif" width="167" height="26"></a></font></p>
<p style="line-height: 73%"><a href="social.htm" target="parent"><img border="0" src="images/calender_off.gif" width="167" height="26"></a></font></p>
<p style="line-height: 73%"><a href="pictures.htm" target="parent"><img border="0" src="images/pictures_off.gif" width="167" height="26"></a></p>
<p style="line-height: 73%"><a href="athletics.htm" target="parent"><img border="0" src="images/athletics_off.gif" width="167" height="26"></a></font></p>
<p style="line-height: 73%"><a href="rush.htm" target="parent"><img border="0" src="images/rush_off.gif" width="167" height="26"></a></p>
<p style="line-height: 73%"><a href="alumni.htm" target="parent"><img border="0" src="images/alumni_off.gif" width="167" height="26"></a></p>

<p style="line-height: 73%"><a href="links.htm" target="parent"><img border="0" src="images/links_off.gif" width="167" height="26"></a></p>

<p style="line-height: 73%"><a href="history.htm" target="parent"><img border="0" src="images/history_off.gif" width="167" height="26"></a></p>

</body>

</html>

Thanks

ACJavascript
07-06-2002, 04:45 PM
Okay well, i kept getting an error on this (its boldfaced)

-------------

<html>

<head>
<meta http-equiv="Content-Language" content="en-us">
<meta http-equiv="Content-Type" content="text/html; charset=windows-1252">
<meta name="GENERATOR" content="Microsoft FrontPage 4.0">
<meta name="ProgId" content="FrontPage.Editor.Document">
<title>Menu</title>
<base target="main">
<meta name="Microsoft Border" content="none, default">

</head>

<body background="images/greek3_copy.jpg" onload="setRollover()">

<p>

<A HREF="faq.html" onMouseOver="document.images['home'].src='images/home_on.gif'" onMouseOut="document.images['home'].src='images/home_off.gif'"><IMG SRC="images/home.gif" width="167" height="26" BORDER="0" NAME="home"></a></p>
<p style="line-height: 73%"><a href="actives.htm" target="parent"><img border="0" src="images/brothers_off.gif" width="167" height="26"></a></font></p>
<p style="line-height: 73%"><a href="social.htm" target="parent"><img border="0" src="images/calender_off.gif" width="167" height="26"></a></font></p>
<p style="line-height: 73%"><a href="pictures.htm" target="parent"><img border="0" src="images/pictures_off.gif" width="167" height="26"></a></p>
<p style="line-height: 73%"><a href="athletics.htm" target="parent"><img border="0" src="images/athletics_off.gif" width="167" height="26"></a></font></p>
<p style="line-height: 73%"><a href="rush.htm" target="parent"><img border="0" src="images/rush_off.gif" width="167" height="26"></a></p>
<p style="line-height: 73%"><a href="alumni.htm" target="parent"><img border="0" src="images/alumni_off.gif" width="167" height="26"></a></p>

<p style="line-height: 73%"><a href="links.htm" target="parent"><img border="0" src="images/links_off.gif" width="167" height="26"></a></p>

<p style="line-height: 73%"><a href="history.htm" target="parent"><img border="0" src="images/history_off.gif" width="167" height="26"></a></p>

</body>

</html>

----------------

When i removed it, the script seemed to work fine :D

mordred
07-06-2002, 05:21 PM
Uhm... that's easy to explain, in case you haven't noticed it yet...
there is no javascript function called setRollover in your document. So it obviously gives an error cause it can't find that function after the page has been loaded. Or do I miss something?



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum