...

View Full Version : Thanks Error



Trinithis
08-19-2008, 09:55 AM
When I tried thanking a user, I got:

Trinithis, you do not have permission to access this page. This could be due to one of several reasons:

1. Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
2. If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.

abduraooft
08-19-2008, 10:05 AM
Lol, no such problem for me! just give up your designation and badge :)

oesxyl
08-19-2008, 10:40 AM
When I tried thanking a user, I got:

Trinithis, you do not have permission to access this page. This could be due to one of several reasons:

1. Your user account may not have sufficient privileges to access this page. Are you trying to edit someone else's post, access administrative features or some other privileged system?
2. If you are trying to post, the administrator may have disabled your account, or it may be awaiting activation.
I guess you don't have javascript disabled, :)
WA move yui library on cf server so blocking yahooapi.com is not a reason.
Last guess could be: buggy garbage collect after some js tests which now interfere with yui.

anyway is a yui related problem. :)

best regards

Trinithis
08-19-2008, 07:09 PM
I found the culprit:

/(adv|[^a-z]ad|client).*?(jpe?g|bmp|gif|png|swf|js)$/

http://www.codingforums.com/clientscript/post_thanks.js


I was thinking it had to do with buggy mod privileges.

oesxyl
08-19-2008, 07:14 PM
I found the culprit:
/(adv|[^a-z]ad|client).*?(jpe?g|bmp|gif|png|swf|js)$/

I was thinking it had to do with buggy mod privileges.
in noscript, yui or some of your work?

look like noscript or addblock filter, :)

best regards

WA
08-19-2008, 07:50 PM
I found the culprit:

/(adv|[^a-z]ad|client).*?(jpe?g|bmp|gif|png|swf|js)$/

http://www.codingforums.com/clientscript/post_thanks.js


I was thinking it had to do with buggy mod privileges.

Hmm can you elaborate? I haven't modified the source of the original post_thanks.js file.

Trinithis
08-19-2008, 08:32 PM
The thank you script location was changed such that my adblock kicked it because it detected client and js in the same uri . . . and I hadn't expected it's location to be modified. I solved the problem by adding a whitelisting
codingforums.com/clientscript/



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum