...

View Full Version : Never seen this before, works perfectly in Firefox3 and not IE7



smillieg
07-20-2008, 04:53 PM
Hello everyone,
I am working on a project to get a new site up and running. I have built CSS sites in the past but for some reason it looks perfect in firefox 3 but the background isn't displaying correctly in IE7 which I've never had before.

The url is http://www.gallusconsulting.co.uk/test/aboutus/abouttest.html

Both my CSS and XHTML validate using the w3c validators which is what is confusing me!

The CSS below should pull in an image which should appear from the bottom of the top nav down to the footer shown in the div midSectionPage.


#midSectionPage {
background-image:url(../images/mainPageBtm.gif);
background-position:bottom;
background-repeat:no-repeat;
}

A link to the image it should display is on this link (http://www.gallusconsulting.co.uk/test/images/mainPageBtm.gif)

Any help or guidance you can give would be greatly appreciated.

jcdevelopment
07-20-2008, 05:45 PM
try this



#midSectionPage {
background-image:url(../images/mainPageBtm.gif);
background-position:bottom;
background-repeat:repeat;
width:/*give the exact width of the image*/
height:/*give the exact height of the image*/
}


Adding the height and width may help in IE, just try it and see what happens.

smillieg
07-20-2008, 05:53 PM
Thanks jcd,
I have tried adding that to the code but it hasn't made any difference unfortunately. What I don't understand is why some pages seem to work in IE and others don't and they use exactly the same templte.

For example, this page looks ok in IE7:
http://www.gallusconsulting.co.uk/test/aboutus/accreditations.html

and this one has the image missing:
http://www.gallusconsulting.co.uk/test/aboutus/ourapproach.html



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum