View Full Version : Explorer vs firefox problem

07-14-2008, 01:12 PM
Hello reader,
I have a problem, which my limited knowledge of webcoding, prevents me from solving. It may be also due to the fact that I'm working on a messy mixture of html and css coding. In the home page, www.sacred-egypt.com (http://www.sacred-egypt.com), there is a difference in the display of my ads. It is perfect on firefox but not on explorer. On the later, the google ad doesnt go until the bottom, and some of my picture over it is squeezed. Can anyone relive me from me from this frustration? :confused: Thank you so much if you can!

07-14-2008, 01:21 PM
There are some markup errors, especially by closing tag mismatch, see http://validator.w3.org/check?uri=http%3A%2F%2Fwww.sacred-egypt.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0
Fix them first.

07-14-2008, 02:18 PM
All the errors that remain concern the jump menu, which work, and which I dont know how to standardize anyway. However there is still this problem of ad positionning. You dont have a clue how to resolve this? Thanks a lot anyway Abdu

07-14-2008, 02:40 PM
Around line 57 of stylehome.css , change

float:left; /*right way to apply float */
display:inline; /* IE 3px hack*/
width:588px; /* to compensate IE box model bug */

07-14-2008, 02:45 PM
Im very happy, I think I managed on my own. I changed the html definition of css relation and changed css values. seems to work. I will try your suggestion to experiment with the result ;-) Thanks a lot !!! You're great helper as always.

07-14-2008, 02:56 PM
I added your suggestions to the css code and it seems that the content text is not centered anymore (there is a bigger margin on the right side than left side). Dont have a clue why though... have a look if you can. Shukran gazira