...

View Full Version : LI OL Style not working



UrbanTwitch
07-14-2008, 01:34 AM
http://sodadome.com/

Go there in the green menu there should be: http://sodadome.com/sep.png after every word.

So I go to style css and here is the css:



#greenmenu ol li {
background: url(sep.png) no-repeat 100% 100%;
padding-bottom: 7px;
padding-right: -1px;
padding-left: 0px;
margin-left: 10px;
}


and here is HTML



<div id="greenmenu">
<ol><img src="gsep.png" border="0" height="4px" width="10px" style="float:left;"><li><a href="http://sodadome.com">Home</a></li>
<li><a href="http://sodadome.com/gallery">Gallery</a></li>
<li><a href="http://sodadome.com/aboutme">About Me</a></li>
<li><a href="http://sodadome.com/aboutsite">About Site</a></li>
<li><a href="http://sodadome.com/contact">Contact Me</a></li>
</ol>



<?php
if($logged[id]) {
//welcomes the member
echo "<font color=white ><b>Welcome <a href=http://sodadome.com/members.php?user=$logged[username]>$logged[username]</a> (<a href=http://sodadome.com/logout.php?logout>Logout</a>)</b></font>";
}
else {
echo "<a href=http://sodadome.com/login.php>Login</a> or <a href=http://sodadome.com/register.php>Register</a>"; } ?>


</div>

What's wrong?

_Aerospace_Eng_
07-14-2008, 03:59 AM
Its because the stylesheet looks for the image in the temp2 folder but its in the root of the site so try

background: url(/sep.png) no-repeat 100&#37; 100%;
And you can't have negative padding.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum