...

View Full Version : connecting to DB?



freefallenigma
07-07-2008, 04:30 PM
Hello,

I can't seem to connect to a database on my mac, but I can on the Linux machine I'm working on. I get an "Unknown Source" issue. Here's the error my mac gets when I try to load the app:
HTTP Status 500 -

type Exception report

message

description The server encountered an internal error () that prevented it from fulfilling this request.

exception

java.lang.NullPointerException
at.PasswordValidator.validatePassword(Unknown Source)
at.LogController.login(Unknown Source)
sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
java.lang.reflect.Method.invoke(Method.java:585)
org.springframework.web.servlet.mvc.multiaction.MultiActionController.invokeNamedMethod(MultiActionC ontroller.java:351)
org.springframework.web.servlet.mvc.multiaction.MultiActionController.handleRequestInternal(MultiAct ionController.java:305)
org.springframework.web.servlet.mvc.AbstractController.handleRequest(AbstractController.java:128)
org.springframework.web.servlet.mvc.SimpleControllerHandlerAdapter.handle(SimpleControllerHandlerAda pter.java:44)
org.springframework.web.servlet.DispatcherServlet.doDispatch(DispatcherServlet.java:684)
org.springframework.web.servlet.DispatcherServlet.doService(DispatcherServlet.java:625)
org.springframework.web.servlet.FrameworkServlet.serviceWrapper(FrameworkServlet.java:386)
org.springframework.web.servlet.FrameworkServlet.doPost(FrameworkServlet.java:355)
javax.servlet.http.HttpServlet.service(HttpServlet.java:710)
javax.servlet.http.HttpServlet.service(HttpServlet.java:803)

I'm using EasyEclipse for the app, and Apache Tomcat.
Is this an issue connecting to the DB? Any ideas on why this is happening? Thanks.

brad211987
07-07-2008, 07:28 PM
Without more information, my guess is that the password for the DB user is not getting submitted. This is based on the NullPointerException in the validatePassword method.

freefallenigma
07-07-2008, 07:37 PM
We're using SVN and I am updated to the newest revision. I don't recall exactly when it stopped working but a week ago I could connect fine, though now that we've added more to the application, DB connection is essential. Hm.

What kind of info would be more helpful?

We're using Spring-MVC
My Mac: MacBook Pro 10.5.4

Thanks!

brad211987
07-07-2008, 08:21 PM
To troubleshoot, I'd check over the code that is actually doing the database connection that fails. Run the code through a debugger and see if there is a value for a password in the application at the time of failure. I would definitely focus on the changes/additions made to the application to ensure no conflicts there as that is the most likely cause.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum