...

View Full Version : javascript + mozilla issue



firepages
02-06-2003, 04:14 AM
in this page ..(I have stripped out all the content to make it a liitle more readable) http://www.consciousliving.net.au/test.html

the mouseovers on the 'Practitioners','courses' and 'articles' links all do strange things in Mozilla and IE5 for mac

What puzzles me most is that this whole page is generated by script, so if one mouseover does not work then none of them should ? but its just those 3 links?

anyone see where I stuffed up? (in this regard at least ;))

BrightNail
02-06-2003, 05:38 AM
what sort of strange things? --> try to be more specific as I am not on a mozilla or mac..yet, if you can describe the issue,,we might have run across it before...

Skyzyx
02-06-2003, 05:14 PM
I also see the error on Moz for Windows. I'll check it out and get back to you...

Skyzyx
02-06-2003, 05:20 PM
You've given the wrong images the wrong ID's.

This is what you've got:


<tr><td><img src="img/bull_smallO.gif" border="0" /></td>
<td><a href="catalog1.html" onmouseover="iswap('uber1');">
<img id="uber1" src="img/uber1.gif" alt="" border="0" /></a></td></tr>

<tr><td><img id="uber2" src="img/bull_smallO.gif" border="0" /></td>
<td><a href="catalog2.html" onmouseover="iswap('uber2');">
<img id="uber2" src="img/uber2.gif" alt="" border="0" /></a></td></tr>

<tr><td><img id="uber3" src="img/bull_smallO.gif" border="0" /></td>
<td><a href="catalog3.html" onmouseover="iswap('uber3');">
<img id="uber3" src="img/uber3.gif" alt="" border="0" /></a></td></tr>

<tr><td><img id="uber4" src="img/bull_smallO.gif" border="0" /></td>
<td><a href="catalog4.html" onmouseover="iswap('uber4');">
<img id="uber4" src="img/uber4.gif" alt="" border="0" /></a></td></tr>


This is what you should have:


<tr><td><img src="img/bull_smallO.gif" border="0" /></td>
<td><a href="catalog1.html" onmouseover="iswap('uber1');">
<img id="uber1" src="img/uber1.gif" alt="" border="0" /></a></td></tr>

<tr><td><img src="img/bull_smallO.gif" border="0" /></td>
<td><a href="catalog2.html" onmouseover="iswap('uber2');">
<img id="uber2" src="img/uber2.gif" alt="" border="0" /></a></td></tr>

<tr><td><img src="img/bull_smallO.gif" border="0" /></td>
<td><a href="catalog3.html" onmouseover="iswap('uber3');">
<img id="uber3" src="img/uber3.gif" alt="" border="0" /></a></td></tr>

<tr><td><img src="img/bull_smallO.gif" border="0" /></td>
<td><a href="catalog4.html" onmouseover="iswap('uber4');">
<img id="uber4" src="img/uber4.gif" alt="" border="0" /></a></td></tr>


Hope this helps!

firepages
02-06-2003, 06:30 PM
agghhhhhh - bangs head against wall :)

I thought that all of the left hand menus were generated by (PHP) script which is why I was so totally confused as to why all but three worked...

looking at the page builder though those first 4 'uber' categories are hand coded.. so I stuffed up


Cheers Skyzyx ! - I stared at that code for I dont know how long and did not see that ! , much appreciated.



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum