...

View Full Version : php 4.1.2 cgi module, cant find the right version to download



sarah
02-05-2003, 11:28 AM
Hi all!

I've been hosting my site externally for awhile now and still fairly new to php. My host has upgraded their php from 4.0.6 apache module to 4.1.2 cgi module. The problem is some parts of my website are not working as they should and I get a lot of internal server 500 errors on random pages. I tried to find this version to download and see if on the test area I get the same problems or errors, but I cant seem to find a bundle or patch to upgrade php 4.0.6 to 4.1.2

Please help!!!

Thanks in advance
Sarah

mordred
02-05-2003, 03:08 PM
http://ftp.proventum.net/pub/php/

Some server/environment variables are not available in CGI/Module mode, if that helps you locating the source of the error.

firepages
02-05-2003, 03:19 PM
no help I know but if your host has chosen CGI over an apache module.... well unless they pay you for the pleasure of hosting ;) I would look at finding another host.

'upgrading' to PHP4.1.2 is very strange, 4.2.* would be the minimum for those paranoid about the latest and greatest 4.3.0 , as for module > CGI :confused:

sarah
02-05-2003, 04:20 PM
thanks guys for the quick response and the link to the ftp site. I've now downloaded and extracted the files to a temp folder, has anyone tried upgrading from php 4.0.6 apache to 4.1.2 cgi?

Its jus if anyone can give me some advice on how to go about it it will make my life much easier. I'm not how to configure or setup php for a cgi module. Any ideas?

If anyone has an example of how to setup php in cgi module or has setup php in cgi module then please let me know. All help and advice is appreciated.

Once again thanks u guys
Sarah

Jesh
02-05-2003, 08:14 PM
Hey

Everything, from coding to installing is pretty self explanatory on PHP.NET (http://www.php.net/manual/en/installation.php).

Jesh



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum