View Full Version : bullet points don't show up in IE7, but do in FF2

05-20-2008, 12:21 AM
Can anyone tell me why the bullet points on this page don't show up in IE 7?


I've never encountered anything like this before and I don't even know where to start.

Thanks a lot.

05-20-2008, 01:04 AM
#nav ul {

CSS levels required for CSS List Properties by Browser:
-IE: 4
- FF:1
- NS: 6
- W3: 1


... (CSS level 2.1) ...

It would appear that the browser CSS reccemendations could be the problem. However, tested in NS6 and works. Despite that, I'm sure its some problem having to do with the CSS list properties.

05-20-2008, 03:35 AM
I've been playing with the CSS and can't seem to fix it. I removed the list related stuff and it didn't work. Do you have any idea?

05-20-2008, 03:53 AM
Wow, lol. I have it. I completely missed this in the first place.
list-style-type:none; That piece of code is making IE render the list with exactly that type of bullet: none. To achieve the same effect and make it work with IE, just change it to

Sorry I missed that at first, hope this helps. :)

05-20-2008, 04:09 AM
I made that change and I still don't get bullets. I figured maybe it was loading a cached version but I did a hard refresh and I still get the same result.

05-20-2008, 07:04 AM
Are you floating the lists? Make sure to give them enough margin or padding to show the bullets; in IE the bullets will "hide" behind the element they are floated next to.

05-21-2008, 04:43 AM
Could I put the content that the bullets are in, in a class? Then define the list to show up? That would over ride the ids yeah?

05-21-2008, 03:17 PM
Yes, you could try that. Also did you check rmedek's solution? At this point I would play around with all the sizes, borders, paddings, list properties, etc effecting the list, since you've already tried several solutions that don't work.

08-20-2008, 10:28 AM
Are you floating the lists? Make sure to give them enough margin or padding to show the bullets; in IE the bullets will "hide" behind the element they are floated next to.

Thank You!

I've been struggling with an issue just like this for the last hour and a half! I tried everything all the way to removing all mention of "list-style:none" from my CSS without anything working.

Until I specified "padding-left:20px;"

Damn IE7!

08-20-2008, 10:32 AM
Glad it worked for you :thumbsup:

08-20-2008, 10:36 AM
I suppose it’s not the padding that was the issue (although a left padding/margin of zero makes the bullets go outside of the list – see it by applying a border to the list). The problem here is that list bullets being outside of the list are hidden in IE unless you do something to the list items with hasLayout (http://satzansatz.de/cssd/onhavinglayout.html) or position them relative or something like that (I don’t have it in mind right now what exactly it is).

08-20-2008, 07:58 PM
I suppose itís not the padding that was the issue

Öno, but it's a quick fix. :thumbsup:

08-20-2008, 08:09 PM
Indeed it is. I just wanted to clarify for the records.