...

View Full Version : .htpasswd



mcr
04-28-2008, 08:11 PM
i am trying to get it to work on my website.

i am using 1and1.com as my host.

i want to protect a directory - www.thegdbgroup.com/protectedtraining

just to test it, i put the htaccess file and htpasswd file in there

but there is no password box when i go to the site.

anyone can help?

htacess file-
<Directory protectedtraining>
AuthType Basic
AuthName "Memeber Login"
AuthUserFile www.thegdbgroup.com\protectedtraining\.htpasswd
Require valid-user or require user username </Directory>

anyone can help?

abduraooft
04-30-2008, 05:04 PM
I think you are confused with the httpd.conf and htaccess syntaxes.
See, http://home.golden.net/htaccess.html (you need to specify the full absolute path of the password file)

oesxyl
04-30-2008, 07:08 PM
Don't use Directory and make AuthUserFile absolute path. Also be sure your browser cache and authentification stored is clear.

this can help you:

http://www.apacheweek.com/features/userauth

regards

mcr
05-01-2008, 12:34 AM
ok i found the full path to my htpasswd file.
so this is what i have.


AuthName ?Restricted Area?
AuthType Basic
AuthUserFile \homepages\31\d195789388\protectedtraining\.htpasswd
AuthGroupFile \dev\null
require valid-user
Options +Indexes

it still does not work.

someone help me.

this is located at www.gdbgroup.biz/protectedtraining

oesxyl
05-01-2008, 12:43 AM
ok i found the full path to my htpasswd file.
so this is what i have.

AuthName ?Restricted Area?
AuthType Basic
AuthUserFile \homepages\31\d195789388\protectedtraining\.htpasswd
AuthGroupFile \dev\null
require valid-user
Options +Indexes

it still does not work.

someone help me.

this is located at www.gdbgroup.biz/protectedtraining
why don't mention that you use a Microsoft-IIS server?
the link I post is for Apache, I don't think this work for you.
Unfortunately I can't help you. I'm sorry.

regards

mcr
05-01-2008, 12:55 AM
why don't mention that you use a Microsoft-IIS server?
the link I post is for Apache, I don't think this work for you.
Unfortunately I can't help you. I'm sorry.

regards

HAHA :) i didn't know the difference. My server will now be switched to linux :) hopefully it will work now

oesxyl
05-01-2008, 01:25 AM
HAHA :) i didn't know the difference. My server will now be switched to linux :) hopefully it will work now
:), in that case maybe I and the posted link could help, :)

this are the settings for auth basic


AuthType Basic
AuthName "the realm used in htpasswd"
AuthUserFile /path/to/htpasswd
require valid-user


- on linux you must use / instead off \ in path
- use what you need for realm and htpasswd path.
- be sure you update/create htpasswd and is on the path you use in .htaccess

regards

mcr
05-12-2008, 03:15 PM
how do i delete this thread or edit it.

oesxyl
05-12-2008, 07:01 PM
how do i delete this thread or edit it.
probably the moderators can help, I see that edit buttons are unavailable at this moment, probably the thread is closed.
Let me know if I can help with something.

I guess that I must edit some of my replays too, or maybe I'm wrong
regards



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum