...

View Full Version : Server Error - Error 500



saeed
02-27-2008, 09:14 AM
I've running a PHP link indexing script on my home computer.

Windows XP Pro SP 2
XAMPP

Error Message:

Server error!

The server encountered an internal error and was unable to complete your request. Either the server is overloaded or there was an error in a CGI script.

If you think this is a server error, please contact the webmaster.
Error 500
localhost
02/27/08 13:04:31
Apache/2.2.6 (Win32) DAV/2 mod_ssl/2.2.6 OpenSSL/0.9.8e mod_autoindex_color PHP/5.2.4

I believe its something to do with .htaccess file (source google)
any idea about this error and how to solve this ?

thanks,

kbluhm
02-27-2008, 01:27 PM
Right out of the gate, .htaccess files are useless on Windows machines.

oesxyl
02-27-2008, 03:23 PM
I believe its something to do with .htaccess file (source google)
any idea about this error and how to solve this ?

thanks,
I don't know if this is available on windows, you must find yourself
there is a a script named 'apachectl', you can run it using:

apachectl configtest

this can give some usefull info, if is .htaccess faoult will complain but looking to kbluhm replay this seems useless.

another way:

you must have somewhere some logs file, access and error, look inside to see what happend.

good luck and best regards

_Aerospace_Eng_
02-27-2008, 04:00 PM
Mod_rewrite needs to be enabled on xampp for htaccess to work. Its an apache server by the way so htaccess does work.

Find the file called httpd.conf, it should be located in
XAMPPInstallDirectory\apache\conf\

Open with notepad and find this line

#LoadModule rewrite_module modules/mod_rewrite.so
Remove the #, save it, restart apache (if running).

kbluhm
02-27-2008, 04:32 PM
Ah, sorry about that. I saw Windows and IIS popped into my head without even thinking.

saeed
02-28-2008, 05:36 AM
thanks for your reply guys .. honestly I dont know why it was not working but after spending an hour on google. all i did just rename the file .htaccess to htaccess.txt

thats it!

and its working fine now :)

aedrin
02-28-2008, 06:19 PM
thanks for your reply guys .. honestly I dont know why it was not working but after spending an hour on google. all i did just rename the file .htaccess to htaccess.txt

thats it!

and its working fine now :)

That would disable the .htaccess file... I'm not sure if that means it is working (I suppose you no longer get an error).



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum