...

View Full Version : Header Help!



CanadianPilot
02-21-2008, 11:39 PM
I've been searching and testing for 2 days, and just cannot figure this out.

http://www.BCGolfers.com/forum/

I have a logo that I want on the left side, flush with the green bar. I would like an Adsense banner on the far right side of the header, floating in the middle.

I actually had things working in Safari, but now I've completely messed it up and the logo shows in IE and the Adsense in FF. But cant get both to show at the same time.

CSS

/* ***** sets background for header area - No need to change this ***** */
#hdr {
background: #FFFFFF url(iSkin/misc/hdr_back.gif) ;
width: 100%;
height: 122px;
margin: 0;
padding: 0;
}

/* ***** dispalys 1 px border around header area - No need to change this ***** */
#hdr_bdr {
border-left: 1px solid #FFFFFF;
border-right: 1px solid #FFFFFF;
margin: 0;
padding: 0;
}

/* ***** SETS LOGO AREA FOUND IN HEADER AND ALL OF IT'S PROPERTIES ***** */
#logo {
background: url(iSkin/misc/BC_logo.jpg);
width: 418px;
height: 122px;
align: left;
margin: 0;
padding: 0;
}

/* ***** Sets Header Ads ***** */
#hdr_ad {
width: 468px;
height: 160px;
float: right;
margin: 30px;
padding: 1px;
}



Header excerpt

<!-- begin iSkin header / logo is controlled via #logo in main CSS file -->

<div id="hdr_bdr">
<div id="hdr">
<div id="hdr_ad">$header_advertisement</div>
<div id="logo">
</div></div>
<div id="hdr_btm"></div>
<div id="nav_back"></div>



Thanks for your help!

_Aerospace_Eng_
02-22-2008, 12:07 AM
You need to use float:left; not align:left; on the logo. align:left; isn't even valid CSS.

CanadianPilot
02-22-2008, 03:15 AM
I would love it to look like this:

CanadianPilot
02-22-2008, 03:41 AM
Its working in the latest version of Firefox now, but not Safari.

I have incredible respect for you coding experts. I'm driving my self crazy with this stuff.
:eek:

_Aerospace_Eng_
02-22-2008, 05:24 AM
logo needs to come before the ad.

CanadianPilot
02-22-2008, 06:03 AM
Putting it after the logo makes it 'float' on top of the logo.

:(

_Aerospace_Eng_
02-22-2008, 07:11 AM
I didn't say that the ad needed to go in the logo. I said it needed to come AFTER the logo.

<div id="hdr">
<div id="logo"></div>
<div id="hdr_ad"></div>
</div>

CanadianPilot
02-22-2008, 08:30 PM
This isnt fun anymore.

I think I'll just give up. I can't get it too work. Now none of my ads show up in safari. I dont get it. Clearly in over my head.
:confused:

Thanks for all your help!



EZ Archive Ads Plugin for vBulletin Copyright 2006 Computer Help Forum